Open polysurface issue after lofting curves? I need it closed

Hi guys!

I hope someone can help since I am still a beginner. After creating a series of curves in grasshopper and lofting them, I am facing the issue of the polysurface being open instead of closed. In the edge analysis I see that I have a few naked edges which I do not know how to fix. I assume this could be the cause of the polysurface being open rather than closed? I need it to be closed in order for a waffle script to work for laser cutting. Any help is much appreciated.

Here are my files
Grasshopper file (32.7 KB)
Rhino file Lejla.3dm (632.5 KB)

Don’t quite understand what you’re after. You can close the loft (first option on the Loft Options) then you’ll get a closed polysurface but I suspect that’s not your design intent . Right now you’ve just created an open surface - you need to specify how it’s closed in order to arrive at a solid.

If all you want is a guide for lasercutting then the open surface should suffice?