Not Smooth

Hi, I´m doing a simple cylinder and then some filleting. How can I do to achieve more smoooth surfaces?
curved surfaces seem segmented and a sumatory of small segments. I tried strating from a circle, then rebuild an extrude, but is not better. I need smooothness for macro detailed photos with keyshot.

Uploaded an image to see it the faceted surface:

Hello - please see-

https://wiki.mcneel.com/rhino/meshfaq
http://www.hydraulicdesign.net/meshes.htm

Does that help?

-Pascal

It´s not a mesh, it´s a polysurface.
You suggest turn it into a mesh??

Unfortunately Pascal put the links in reverse order. If you look at the second one, you can see that NURBS surfaces can’t be displayed directly, the software creates a “display mesh” so that the surfaces can be seen in the viewport. These change automatically as the surfaces are changed.
In your case Rhino is using a coarse mesh, which though more efficient, tends to show its facets at the edge of a curved object.
So read the second link to understand the problem and then the first link to see the ways that the display mesh can be tuned up.
Nick

Just to understand…
Rhino use nurbs, supposedly because the are precise and smooth, but what i can see is a coarse mesh (don´t know well if this is a “normal” mesh or not) so… to render (and what is more important…to FAB… have to treat the supposedly nurbs as meshes??

The solution is convert them to meshes?

I´m a bit confused.

Don’t be, As you say, Rhino uses Nurbs unless you say anything else. And it follows, you use these Nurbs surfaces for fabrication as well (if that’s you intention).

It is only for display purposes Rihno converts the Nurbs to mesh. But, if you would want that, you can also save your Nurbs surface as a mesh, if that’s what you want (although you would normally use a mesh tool if that was the intent from the beginning).

So again, Rhino surfaces are Nurbs surface, but what you see on screen in a mesh representation of that surface. In order to get a smother mesh on screen you adjust the mesh settings.

Hey
Read Nick’s post again, “Display” is the word to focus on.

RIL
I think your word “converts” will still be confusing.
Rhino creates a mesh based on the nurbs and mesh setting to “display” a visual representation of the nurbs.the nurbs are still there and do not change unless you change them

1 Like

Ok, already change the mesh display settings.

So the important thing is: mesh is only there for visual purposes, and when unrollsrf, flatten and so, esentially when i work with plans, the surface will be as always be, nurbs, and will be absolutely precise, isn´t it?

Ah, yes, you are perfectly right. Bad choice of words. :slight_smile:

// Rolf

Yes.

Thanks for the answers, to everyone.

just to be precise, that might not be utmostly correct.

Technically maybe not, but that seems to be the situation, for all practical purposes. (I’m not a computer scientist.)

I am having a similar issue.

I made a nurbs cylinder using cylinder command in Rhino. I am getting these faceted surface.

What should I do get smooth surface?

Looks like you might have Flat Shading turned on in your display. Check the viewport drop down menu and if it is checked, uncheck it.

1 Like

Thanks! That worked. :+1:t4: