Not Selecting / Disappearing Annotations


(Jonathanm) #1

I recently upgraded to Rhino 6 at work. The first project I’m working on was importing a somewhat large CAD file of a site plan.

For some reason I noticed a lot of the small annotations and dimensions disappear when zoomed out, and because of this I cannot select them. I never had this issue in Rhino 5.

Also related is when I zoom region or zoom window into a specific area, then pan somewhere else, my annotations also disappear until I perform a zoom region on that area. Again I never experienced this in Rhino 5.


(Pascal Golay) #2

Hi Jonathan - can you run the SystemInfo command in Rhino and paste the results here?

-Pascal


(Jonathanm) #6

Hi Pascal,

Below are the system info details.

Rhino 6 SR10 2018-11-4 (Rhino 6, 6.10.18308.14011, Git hash:master @ fe550872b75586dc406c587a5ca01f205673c8f1)
Licence type: Commercial, build 2018-11-04
License details: Cloud Zoo. In use by: m moser ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: HKG-4N8Z0L2

Quadro M4000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 369.39)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 9-18-2016
Driver Version: 21.21.13.6939
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18308.14011
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18308.14011
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\jonathanm\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2017.11.15.520\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18308.14011
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18308.14011
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Pascal Golay) #7

Hi Jonathan- a couple of things - one is your video card driver is a couple of years old - whether or not that comes into play in this problem, it is probably a good idea to get the latest, from the NVidia website - (don’t rely on the Windows check for the latest).

The other thing is I was reminded by the developer that V6 has a ‘degrading’ of annotation below a certain size to lines and then it goes away - so, is there a stage in your operations where the disappearing annotations become lines before they disappear?

-Pascal


(Jonathanm) #8

Hi Pascal,

Thanks for the advice regarding the video driver. I will try to manually update from the website and see if that makes a difference.

Also, yes the annotations turn to lines at a certain distance. Actually I am fine with this graphically, but the main problem was not being to select them at all if they degrade all the way to disappearing. Is there a way to disable this effect?

Thanks,
-Jon


(Pascal Golay) #9

Hi Jon - looking at this here, Dimensions do not disappear as a whole, but the dimension text showing the value disappears - are we seeing the same behavior? For text blocks, I think the problem may be, that an entire block of text will disappear if the individual test elements get below a certain size, even if the overall block of text should be visible, maybe as a solid rectangle or something, am I on the right track?

-Pascal


(Jonathanm) #10

Hi Pascal, I was going to make a screencapture but now I can’t seem to get it to behave the same way… maybe it was just a fluke from running too many things at once or something… It was not a whole block of text disappearing, but rather individual texts in a close region. Also I was operating in Top View as well when this was still happening, so it wasn’t a perspective issue. Hoping it was just a random issue. I’ll post a follow up if I can get it to behave like that again.

Thanks,
-Jon


(Pascal Golay) #11

Hi Jon - ok - if you see it again and can come up with steps to reproduce, that would be ideal, but I know about these hard to reproduce deals, they can be frustrating.

-Pascal