No class derived from CRhinoPlugIn in plug-in file

Hello,

One of my customers contacted me today saying that they’re getting an error when they try to load ExactFlat. A message box comes up saying “Unable to load ExactFlat.rhp: no class derived from CRhinoPlugIn in plug-in file.” This is a new error that the customer was not having last week. The plug-in version has not changed, and no updates have been made to Rhino since last week. I’ve had them uninstall and re-install just in case something happened to the plug-in, but that’s not helping.

The plug-in is being run on Version 5 SR9 64-bit (5.9.40609.20145, 9-6-2014). I’m currently running the exact same version, and ExactFlat loads just fine for me. I haven’t had any other bug reports of this nature.

I’m at a loss as to what the problem may be. Nothing has changed. Any ideas?

I’m a little confused about this date, as we ain’t there yet.

9 june 2014 :wink:

Geez, I need a weekend…

2 Likes

Me too, and a beer!

Any ideas anyone? Dale? Steve? Can one of you please tell me what the conditions are for this message to be shown? I can’t even reproduce the error message, and trying to debug it without even knowing why the message is being shown isn’t easy. Any ideas or pointers on where to look would be greatly appreciated.

What version and service release (number and date) of Rhino are you trying to load your plug-in into?

Is the problem with 32-bit Rhino 5, 64-bit Rhino 5, or both?

What version of the Rhino C++ SDK did you build your plug-in against?

What service releases of Visual Studio 2010 and 2005 did you build with?

This is not a common problem we hear about (from our developers). So we might go back and forth a bit…

Rhino 5 SR9 64-bit (5.9.40609.20145, 9-6-2014), please see attached screenshot. Please note that this is happening on a machine in the Netherlands, so the date/time format is d-m-yyyy.

The problem is with Rhino 5 64-bit.

Rhino5x64_d.exe has a file version of 5.3.30426.17065. Please let me know if this isn’t the SDK version, and if so, where to find it. I don’t think I have the installer anymore.

Please see the attached vs2005.txt and vs2010.txt files for versions and updates to Visual Studio 2005 and 2010.

vs2005.txt (3.4 KB)

vs2010.txt (4.7 KB)

Hi Luke,

A few more questions:

Can you repeat the problem? If so, what version of Rhino are you using?

Also 5.3.30426.17065, is the Rhino 5 SR3 C++ SDK. Did you build your plug-in with Microsoft Visual Studio 2010, Version 10.0.40219.1 SP1Rel or with an earlier SR?

If you build a customer an updated version of your plug-ins using the SR 9 SDK, does the problem persist?

Just compiling facts…

If nothing has changed, I wonder if there is something strange going on with respect to the user’s setup. You might want to try having the user disable all plug-ins that do not ship with Rhino (you can get this list in the PlugInManager) with the exception of course of your plug-in. Then have the user restart and attempt to load ExactFlat. That may give us some clues as to what is going on.

Hi Dale,

Sorry, I can’t reproduce the problem. I’m using the exact same version of Rhino 5 64-bit as the customer.

ExactFlat was compiled using the versions of the Rhino SDK and Visual Studio above. I’ll try updating to the newest SDK and recompile to see if that solves the problem.

Hi Steve,

The situation hasn’t changed. The customer can successfully run ExactFlat on other computers. I’ll try to get the Rhino version numbers from the other computers. The customer has tried uninstalling and reinstalling both ExactFlat and Rhino with no success.

Thanks guys.

Ok just a quick update.

The computer on which ExactFlat DOES work is running the same version of Rhino as the computer that does not work.

The customer disabled all plug-ins that do not ship with Rhino. ExactFlat still does not load and gives the same error message.

Another update. My customer just told me he did a system recovery and now ExactFlat is working. At this point I’m guessing it was a Windows Update that screwed things up? My customer is going to try to remember what was done to the computer before ExactFlat stopped working and let me know if he finds the problem.

-Luke

Well that is a little worrisome. I wonder why your plug-in and not others (just thinking out loud). How can I get a copy of your plug-in?

Hi Dale,

You can download the 64-bit installer here:

This is for the same version used by the customer. I’ll send you an updated link tonight after I rebuild the plug-in using the newest Rhino 5.0 SDK.

Please let me know if you have any questions about the plug-in.

Well, your plug-in installs and load in Rhino 5 x64 on my Windows 8.1 developer box, which is always up-to-date with Windows Updates. So much for that test…

Luke, is your customer running Windows 8.1?

Windows 8.1.

Here is the link to the new build using the Rhino 5 SR9 SDK. I’ve sent it to my customer to see if this makes a difference. I’ll let you know what he says.

FYI: We have observed that exact behavior on Windows 8.1 with the VRayForMatrix plug-in from Chaos Group. And it was in fact a Windows Update that caused the problem.