New UI: First try using Workspaces

Looks great ! I played around with this a bit and organized panels how I like, but then Rhino crashed and everything was lost. That’s ok of course, but I can’t find how I can save my workspace :face_with_monocle: Is the .rui save not implemented in macOS yet ?

Type workspaces in command line.

1 Like

Hi -
I’m probably not the best person to get on this thread as I’ve tried to avoid as many UI elements as possible since pre-Rhino 1 but until someone who knows more about these things chimes in…

I really don’t know what that means. If I understand this other thread correctly, that should still be possible though…

I’m not seeing crashes from you. Did the crash reporter pop up? Do you have specific steps that can be used to reproduce that crash?

From the first post in this thread:

This allows for more items to be docked without cramping the tabs.

See my previous post to see where you can change this.

As far as I understand, the size of the containers is remembered to keep things in place. If one user has bigger icons in their workspace and shares that with someone who has smaller or bigger icons, the size of the container will stay the same to make sure that not everything else starts moving around.

That’s the area where you can resize containers.

As for those other issues, @Piotr , could you save your workspace and post that here?

Since this is the first public release of this new feature, I’d venture to guess that things might change. I’m sure the plan is to have documentation in place when Rhino 8 gets released. Until then, please let us know where you get stuck.

This is an absolute nightmare.
I can’t figure out how to dock the two toolbars to the bottom of the screen and to do it in right order.

If I move it over the status bar and double click it it gets docked to panels and i don 't want it.
I haven’t figured it out also how to have the two toolbars next to each other.
I have tried to rearrange the top toolbar panel but it is another kind of challenge. Toolbars are disappearing while dragging and miraculously they end up at panel toolbar so, after several attempts, i have a 4 MRUs in side panel, as well as line, point and other toolbars.
Everything is counter-intuitive.
I know you are trying hard to fix it, but, please, don’t kill it with over-thinking and over-doing it.
And there is even wrong name for MRU:
Another one: when expansion arrow is pressed, nothing shows or just a tiny bit of it:

And then there is sharing same icon across different toolbars:

And SubD having no icon at all:

I am ranting so much about it, because in my company I am the only one who knows this software rather well, there is maybe 1 moderate user and lots of complete beginners, who is using it in conjunction with GH for sales purposes. I have created scripts with ‘press this, press that’ and you get the nice result.
I am afraid that complete new look and may scare them.

Hi Piotr -

I’m not quite sure where you want your toolbars to dock, so I’m just making an assumption…
When you drag a contain and want to dock it, you need to look for blue squares that appear in available docking sites.

In the following picture, I’m dragging a random container to the bottom right of the UI because I want to dock it to the right of the Osnap control above the status bar. When I get in the vicinity of a docking site, the blue squares appear:

I then hover over the docking site that I want and the little square becomes a blue bar, representing the docked container:

I release the container and it snaps in place:

In the following picture, I’ve put 2 containers next to the Osnap control:

The “Object Snap” is the name of the container, which, by the looks of it, only contains the MRU toolbar. I personally don’t see the use of naming containers but I suppose they need some name…

I’m not sure where the tiny bit is in that picture.
When I dock a container with a toolbar that doesn’t get enough space, clicking on those arrows shows the remaining buttons in that toolbar:

Could you explain the issue here? I don’t use toolbars…

Is that something I should be able to find on my factory-default installation somewhere?

No worries, Piotr, keep the feedback coming.

Hi Wim
I don’t know whether my troubles may come from hardware specs but I really struggled with the new UI.
I have noticed the blue fields appearing in a panels with no further effect.
I have finally found the way of docking toolbars in a same line (not so easy though) but rearranging the order of a toolbars on the top panel made me rage quit WiP :-).
The ability of moving was limited, (from right to left) and every time I crossed the invisible limit (first 6-9) it automatically moved the toolbar to the side panel.
I will give in another try on Wednesday when the new update comes.

Hi Piotr -
Could you export your workspace and post that .rhw file here?
Perhaps with an image of where you want things to be?

Hi Wim
I left it like this:

Now, I don’t know how to remove layers from the right panel.
Dragging with left or right mb is not helping. Options are gone.
Oh! one needs to press the pin, who would thought…

I can take the toolbar out from the top panel, but I can’t bring it back.
Hovering won’t help. Doubclick sends it back to the right panel.

After clicking on the lines or layer text it ends up far away, where it is not welcomed

Another BIG issue:
I can’t freely rearrange the order of the subtoolbars:
Eg: I can’t move GH sub to be in 1-6 position in the top panel.

If I try to do it, it immediately deleting it. I have no idea why the first 6 positions are frozen.
I love the idea of minimizing the side panel but it is anywhere close to what I’d like it to be.

Strangely no .rhw file is found on my computer:

I made the ToolbarReset to start fresh and give it another try.
After the reset I was being able to configure things a little better but arranging the order of a subtools in a top toolbar is a mystery to me.
It is impossible to do it desired way and takes a lot of time. They just refuse shifting.

Hi Piotr -

My top toolbar seem to be different and I’m not sure what you are looking at or what you want to do.

As long as you don’t export your workspace, there won’t be any .rhw files on your computer. In Workspaces, make sure to save your current workspace and then right-click to export.

Hi Wim
What I wanted to achieve was the specific order of subtoolbars at the top panel.

I got there by removing ALL of them first and then slowly adding, one by one, in the desired order.
It is still impossible to do rearranging in first X toolbars without deleting them.
Side note:
the configuration Image +Text for toolbars is not sticking through sessions.

Hi Piotr -

Could you export that workspace and post it?

Is that when you are making new toolbars?

  1. The save icon for exporting Workspaces is inactive here. I can only import new one. (?)
  2. Nope. It won’t stick even for existing ones after reopening sessions.

I’m having the whole set of strange behaviour recently :anguished:

Do you have more than just the default in that list? Can you post a picture with that inactive button?

Hi Piotr - to gat back to defaults, you can run ToolbarReset and close and re-open Rhino - does that seem as expected now?

… but before doing that, you might want to make sure that you’ve saved what you have now - just in case.
From your comment about the inactive export button, I’m guessing that you only have the default workspace in the list so far, and that’s something that you can’t update nor export.

I have used the ancient method to make that screenshot as MBP keyboard won’t allow for that (unless there is some secret shortcut in Windows).

You can see that Export is more greyish than Import.
PS I am not going to reset my toolbar. With no Saving option I won’t be able to restore it.

Hi Piotr -
This is the dialog that I’m looking for:


OK, here is mine:

Hi Piotr -
That’s what I thought, yes.
You can’t modify the “Rhinoceros Default” workspace. You can drag and reorganize UI elements, but that doesn’t change the definition of that default workspace. That’s the factory-default that you can always return to and know that it’s as shipped in any version. You can’t delete, update, or export that workspace.

You need to click on the big + key at the bottom left and save your custom workspace. You can then export and share that with others.

OK, I get it.
What is going to happen to all changes I have made to adapt Default style?
Is it going to be reset with new update?
Can I copy the one I am having now with the new name? Guess I have to try it myself :wink: