Nested block issues

So I am trying to make more use of blocks, but have hit a stumbling block… no pun intended.

I am working on a project with big components that I split up into blocks. Say Block_A and Block_B. I then have a master rhino file that I insert these blocks into, as linked/referenced. I can then work on the model, and if I have to change the components, I go back and edit the blocks individually.

Now Block_A itself has some inserted/linked blocks.

Here is the issue I found: if I delete Block_A, the blocks that were nested inside Block_A remain as part of the layer tree inside my master file, yet no objects are showing, and there is no way to delete the layers. They don’t show up in the BlockManager (can’t get rid of them there) and I can’t select the layers in the layer tree to delete them (since the layer mode is referenced and the layers are greyed out).

When I then re-insert Block_A, it creates a new instance in the layer tree, so effectively the block is now split in two.

I realize this is complicated to describe… I’m worried that as I move ahead with more use of blocks, I’m going to be stuck with a bunch of referenced layers I can’t delete.



Hi Tom - it may be that Purge will clear these if they are really unused.


Hi Pascal - I’m out of the office so can’t send you the file, but purge doesn’t work.

Hi Tom -
Have you tried exiting Rhino and then reopening that file?

1 Like

Hi Wim

I haven’t, but that sounds like a really good thing to try - thanks for the tip. I’m not at my work machine today, but will report back once I’ve tried it.


I can confirm that if I close the file, and re-open, the nested blocks are solved. Purge doesn’t seem to do that.

Hi Tom -

Thanks for confirming that.

We have this issue on the list as RH-29498 and, with the files that are attached to that item, I can reproduce this issue.

When I create all new files, the reference layers are automatically deleted when the blocks instances and definitions are deleted. So, this looks like it was fixed at some point and I’m not sure if that can be made to work with older files. I’m adding a note to that bug item as a clarification.

1 Like