Negative materials


#1

The scene was working fine when it file was new. I made some nice renders and brazil was working nicely untill suddenly I couldn’t add value to the lights in the scene. When I added values less then 0 to the multiplier it corrected itself to 0.0, and values above 1 was registreted. I saved and restarted the prorgam and file and, alltough the light was now working, the materiales was all wrong. The materials in Brazil without mapping was green and alle materials with mapping was negative. All the materials added through the properties panel was ok.

Anybody know why? And how to solve this?

I have Rhino 4.0 and Brazil 2.0


(Brian James) #2

Hi Erlend,

Would it be possible for you to share the file with me? Please use http://www.rhino3d.com/upload and reference ‘For Brian J.’. I’m not sure what the problem is based on your description but it sounds like the textures used in the materials are missing from their original local address or the texture mapping values were changed. Please include all textures in a zip folder or embed them in the 3dm file in Options>Rendering before saving.


#3

I found a temporary solution to the problem yesterday evening. When I deleted all the materials it rendered with the last properties I gave them before they appered negative. At this point I couldn’t make any adjustments, but I got some ok renders for my presentation. In material properties they are still pointed to a plug-in material, but the materials are now gone.


#4

New problem: Since I deleted all the materials I was forced to use Rhinos basic materials on new objects, but I’m not able to change color. When I click the color button nothing happens. Gloss, transparensy and mapping works, but not color or gloss color.


(Andrew le Bihan) #5

Try creating new materials in the material editor.

We don’t know what’s going on, but the model would help.

Andy


(Brian James) #6

Hi Erlend,

Thanks for the file, I copied Andy on my response too so he has the link now. I will need the textures embedded or sent separately though when you can.

If you only have the Rhino basic material available, can you check that Brazil is still loaded and available in the Render Menu>Current Renderer? I wonder if maybe the plugin isn’t loaded or active.