Need help setting camera in scene to my human eye height

Hi,
V5
Read what links have been supplied, they are about what lens mimicks an eye, I am happy with 45mm , internet says go view>Viewport properties, place camera, so try and zoom into my dummy human height, trouble is, having set it to perspective, one small scroll click takes me whizzing past the eye, I normally work in parallel as one can zoom carefully and precisely, never use perspective, disallows close in zooming. Also whilst struggling with this, I find perspective wont even letb me zoom in enough to get anywhere near my camera location, zoom ceases to go any further, so I am forced to use parallel.

Fist attempt I succeed, then place target, so I choose a point on the far off building,
enter 45mm and click ok, the scene is sitting at an angle, though I see the expected amount of the building above the landscape.

any movement of mouse to try and level up the scene sees view lost , I am now above the railings and seeing more than I should be able to see , lost the scene, obviously no mouse movement of scene must happen !

How does one get the view to be level ? I find a right click viewport supplied rotate view so carefully move mouse to rotate sort of level. Can there not be a default that sets camera level with cplane ?

try again, just cant zoom at all now to the ‘eye’. perspective viewport up to its normal antics !

I read of hitting F6 to toggle camera on and off, hit F6 , command line says camera object is hidden, I thought that was to show it !!!???
hit F6 again, cant see anything different in scene, what camera ?
What am I looking for ?
I cant see anything, after a while I zoom right out and start to see a massive long cone, ending at 0,0 which is miles away from the terrain, as terrain came in at its geographical location, not the Scilly Isles (0,0 for UK)

I try to get hold of the end but my subject is now a pinprick.

close file and reopen it, hit F6 cant see anything, zoom out, still nothing.

I just wish to be able to pick a point for the lens tip, pic target, type a focal length value, have the scene horizontal !, be able maybe to pan left to right as a head would pan.

and take a picture !

I try again with view>ViewportProperties, manage to set camera, then target, then choose parallel and type 45mm, hit ok, and unlike the first result, I am now seeing a scene where the camera is hundreds of metres behind the chosen camera point !

Try again ,same result.

I youtube camera and there is just one bad video, 45mins of natter, ( no direct to the point in a hurry this is how its done ) , and its all fuzzy, there has to be something better and refined than a classroom recording and fuzz, it doesnt take 45mins to set a camera up.

Steve

Hi Steve- here’s a script that may help - Unzip, save, drag and drop onto Rhino to add

LevelView
LevelViewPick
LevelViewToTarget
LevelViewToCamera

With the camera showing (F6) you can see what each of these does.

LevelView2 (2).zip (776 Bytes)
-Pascal

Cheers,
that will help level things up, though right click and level view was a good find.

nope, done that, reopen file, select camera locat then target then perspective then 45mm ok it, end up well behind camera, not on balcony but looking at house from across the road !
and its tilted, so type level and choose level view, asks for elevation ?..eh ?

type 10 and it simply raises the view, its still tilted.

try again and choose levelViewtarget, no joy either.

Why doesnt it by default level a view to cplane ?

wish there was a decent video on this. again nothing :frowning:
I am having a nightmare getting the viewport properties to work though,
I see F6 gives me the cone, but trying to manipulate it, place end on target, not happening for me, pick camera themn pick target is best, IF IT WORKS, why am I getting a scene viewed well behind where the camera is, I shouldnt be seeing the camera well out in front, view should be from the camera to target.

I try for a different location, same issue, always end up well behind the camera, as if I left it on a tripod and cycled a few hundred yards behind it to view the scene !

I have managed to create views from two other locations by using ortho views and moving camera point, when in a view I managed to eventually achieve, I saved the first successful view, yet now I choose that named view and instead of giving me that view again, it sends me many hundrds of metres behind the camera, so even saving a view doesnt restore it !

Steve

@Steve1
You’re on the right track using the F6 command and then adjusting the camera node and target from other viewports. You may want to try moving WITHOUT O-Snap turn on; that might be causing the jumping motions.

You can also draw either a point object or line and use those to snap the camera & target. I think your problem of the viewport ‘twisting’ is because you moved the target from one side of the camera to the opposite side; that can cause unwanted rotation. Try using pans and zooms to get the camera and target close … AND then snap to some ‘helper’ geometry.

Don’t forget: as soon as the camera is set-up the way you like, use the Named View command to save it.

I did a course on Architectural Rendering for lynda.com. There’s a lot of camera and lens stuff in the course. If you’re not a member, here’s a link for 10-days free.

There is also the ‘Placecamera and target button’ in the Set View toolbar. It runs this macro:

! _-ViewportProperties _CameraTarget
_Pause _Pause !

-Pascal

Hi,
having copied out to a new file the two buildings , terrain, and the four camera to target lines , it behaves itself.

Something in the original file is causing it to misbehave massively.

I need to dismantle that file until I find the cause.

Unfortunately I cant post it here for the world to see, as its sort of private, but will when time allows get it to Pascal.

I wish though the camera could be independent of the view we have, as soon as I get it set up, then happen to scroll zoom, without thinking, its all lost.
I want to view the camera whilst in perspective mode, F6 only seems to give camera location in ortho views.

Steve

If you save a named view, you can enable the camera widget (Right click on the saved view in the panel) and maneuver it as needed. It has control points as well.

-Pascal