Named Views - animated transitions

In the 2015-09-29 WIP, going from one Named View to another is now animated by default but I do not see a way to turn this off. Typing anim in the search field in the Settings Editor does not yield any results. The animate check box in the Named Views dialog box for the named view is not checked.

Hi Wim - right-click in the named views panel or use the Animation button (maybe that is already what you’re doing) to get at the controls - seems to work as expected here.


gets you to:

Any luck?


I like it!

I used that animation button to see if I could turn it off but that check box is unchecked even though the view behaves as if it were checked.

I can try to check and uncheck the box to see if that makes a difference. But that’ll have to be tomorrow.

@pascal, I’ve now started with a new file - a box and a vertical clipping plane.
Make a new named view called v0 when un-clipped and one called v1 with clipping.

Type v0 and I get an animated transition to the unclipped view. Type v1 and I get an animated transition to the clipped view.

Named Views dialog box > RMB > Animation Settings: the Animate named view restoration checkbox is unchecked. I check it and click OK. v0 and v1 will animate the transition. Go back to the box and uncheck and OK. v0 and v1 still animates the transition.

Are you seeing something different?

Hi Wim - yeah, I do see something different… It obeys the checkbox here. Hold on though! - I am not typing, I am double-clicking the named view. Using -NamedView and typing in V1 etc, I do see the problem you describe.
Thanks =)


1 Like

You clicker, you! :wink:
Btw, you don’t need to need to start the NamedView command.Just typing v1 is enough.

Also btw- there are a couple of changes in NamedView

  • you can drag and drop a named view from the panel onto any viewport to restore to that viewport.
  • The ‘Restore’ menu item in the panel now offers to restore to the current vp or a new floater. In the latter case, the view size is also restored.


1 Like