Named View NOT animating in v6


#1

The view will animate if I use the Named View panel, but I’m looking to get the functionality I had in v5.

In v5, I could do two additional restore options:

(1) Type in the actual name in the command line [finale] and it would animate the view transition.
(2) Use a keyboard shortcut, like F4 = finale, and it would animate the view transition.

in v6, these two cases do not generate any animation. The view just ‘snaps’ to the saved view. Any ideas how to get this function back?

EDIT: More testing = still not working. Any ideas?


#2

I took a look at this post and tried it in Rhino 6. Perhaps I did not repeat your workflow exactly, but hopefully this is on the right track. It seems to work for me:

Sample Video

Kent


(Pascal Golay) #3

Hi Dave - I see this… thanks.
https://mcneel.myjetbrains.com/youtrack/issue/RH-45235

-Pascal


#4

Kent!
Thanks for the video. That has actually helped me figure out a solution to this bug.

The explanation for this feature requirement is that I am recording training videos. In Rhino 5, I could hit one key, which [secretly] triggered the animated restore from my shortcut, and the camera flew back to where I wanted – while I read the video conclusion.

Therefore, I could not stop and type in the commands you demo’d. [Its not fun to watch 75 times!] But, I could use your command sequence for shortcut, which now works – thanks to you.

So, I made a keyboard shortcut as follows [F4] = ‘-namedview restore finale’

That works … thanks to the hyphen hack. Nice!


#5

Good deal Dave - thanks for the feedback, and I was glad I could help in some way. I see what you are getting to as well (cool trick btw) and I was afraid I wasn’t grasping the entire goal. Your question led me the snapshots command so that is what I am looking at next…

Kent


(Dale Fugier) #6

@schultzeworks, this should be fixed in 6.4.

Thanks for reporting.

– Dale


#7

@dale

That is good news! I’m glad I was able to help.

Dave


(Brian Gillespie) #8

RH-45235 is fixed in the latest Service Release