Named Parts in STEP files

unhandled

#1

I’m trying to get some STEP files to a supplier (for them to open in Solidworks) such that each part carries a name in the model tree. All they’re seeing however, is ‘Imported1’, ‘Imported2’ etc. I’ve tried using Object Name in Properties and naming layers by part.

I’m sure I’ve got this to work in the past. Any ideas what I’m doing wrong?


#2

You are not doing anything wrong. Object names from Solidworks to Rhino 5 through STEP format are messed up. I’ve been complaining about that for a couple years. It worked much better in V4.

Dan


(Brian Gillespie) #3

@chuck - can you please take a look at this?


#4

I did a test Rhino5 > STEP 214 > Rhino4 and the names (and colours) came through unharmed.


(Chuck Welsh) #5

Let me make sure I understand the problem.

Matt, you have a Rhino5 file with named objects, you write it as STEP, read it into Solidworks, and the objects are not named correctly. However, if you read that STEP file into Rhino4, the names are OK there. Are they OK if you read it into Rhino5?

Dan, you are saying that if you write a STEP file from Solidworks, the names do not show up correctly when you read it into Rhino5 but it was OK in Rhino4.

There are several places that an object’s name can be stored in a STEP file. It seems Rhino and Solidworks use different places. I’ll just have to figure out which one Solidworks uses.

Matt, can you send me (chuck@mcneel.com) a simple 3dm file that has the problem?

Thanks,
Chuck Welsh


#6

The same file also imports correctly into Rhino5. I only used 4 in a pathetic attempt to distance the ‘importer’ from the ‘exporter’. Either way, the info is being read form the STEP file, so I don’t think Rhino is at fault. I’ve sent Rhino STEP files to another SW user in the past and they’ve imported fine.

Reading the SW help file, there are a couple of settings in the none-too-helpful SW import options that might be worth tweaking - ‘Import multiple bodies as parts’ and ‘Map configuration data’. I’ve emailed the metalworker and asked him to try them.


#7

Yes, exactly. In V4 the naming of objects from Solidworks via STEP was maintained. In V5 the naming is lost. It seems that the object name in Rhino is a feature of the object. So instead of the object being named “handle” like it was in SWX, it will become “hole” or “slot” in Rhino.

Dan


(Chuck Welsh) #8

In a STEP file, as in most any other file format, there are geometry objects and instances of those objects. Both types have names. It seems the names you are seeing come from instances,but you want them from the geometry, or something like that. I’ve looked at this complaint in the past and it turned out that the STEP import was correct but names of things got messed up when the user exploded blocks in Rhino, after importing, to get down to just the geometry. If that is still the case, then the issue is with the explode command. Can you send me a simple STEP file and explain exactly how you are determining the names of the objects?
Thanks,
Chuck Welsh


(Chuck Welsh) #9

Thanks. Please let me know what you find.

Chuck Welsh


#10

I will prepare something tomorrow.

Dan


#11

SW_user tried changing both options without success. Importing bodies as parts splits the ‘assembly’ into individual part files, but the resulting parts are named document_1, document_2 etc. Component colours import correctly.

SW_user is now getting in touch with their helpdesk.


#12

Hi Chuck,

I’ve prepared a series of illustration which will hopefully explain this better.

Here is the file naming in the original Solidworks file:
![SolidWorks naming.png][1]

Here is the result in Rhino V4 after exploding down to the polysurfaces:

![Rhino import V4 results.png][2]

You can see that the original name is maintained (with some jibberish in parenthesis which is easily ignored)

Now, here is the results in V5. The first illustration is the initial import before exploding anything:

![Rhino import 1.png][3]

Now, after exploding once:

![Rhino import 2.png][4]

Now, exploded a second time to get down to the polysurfaces:

![Rhino import 3.png][5]

Notice that the the object names are now a feature description from Solidworks. This is the problem. The original object naming is lost, and replaced with something completely useless.

I have the STEP and SWX files available if you would like to test with them.

Thanks,

Dan
[1]: https://www.filepicker.io/api/file/crHhBoGQfGaxTMj5yseN
[2]: https://www.filepicker.io/api/file/bKnMN3YjQDSHGThx4EFN
[3]: https://www.filepicker.io/api/file/Ox4RLAUHSoOHfw7At0hc
[4]: https://www.filepicker.io/api/file/MHVIG1IBSkOU9rn89jwH
[5]: https://www.filepicker.io/api/file/sNtUYzpzR1Cio3aaihv4


(Chuck Welsh) #13

Hi Dan,

It looks like the difference between v4 and v5 is in how objects get named in the “Explode” command. In v4, the objects inherit names from the parent block. In v5, you get the name of the geometry object. My guess is that the new method is necessary for someone else’s workflow. I will see if we can have an option on the command, or something.

Thanks,
Chuck Welsh


(Chuck Welsh) #14

Hi Matt,

Is there any chance I can see the 3dm and step files? If not, can you search the step file for one of the names and copy any lines that contain it? Otherwise, I can probably get access to Solidworks early next week and see if I can repeat what you are seeing. And of course I would like to know what you find out from the Solidworks help desk.

Thanks,
Chuck Welsh


#15

Yes, I can email them to you. Are you just chuck@mcneel.com?

Unlike Dan, I don’t have direct access to SW, so he is far better placed to help out with this.


(Chuck Welsh) #16

Yes, that’s my email. We have a copy of SW in the office but the person who has it isn’t around this week. Thanks for sending the files.

Chuck


(Antoine Cbenoit) #17

Hi, I am having the exact same issue. Exporting step file from rhino 5 doesn’t retain the part name when opened in solidworks. Was this thread solved ? Thank you.