Rhino 6 Export File Part Name Not written in Step File

rhino

(R.Jaison) #1

Hi,

I am having difficulties with Rhino 6 Export.

I am trying to read the Rhino Exported Step file in Abaqus for some reason part name are not reading properly.

Below is a simple example of 5 Simple cubes I have name them Cube Test A, Cube Test B…to Cube Test E.

But when I read it in Abaqus

It puts the Part name in Abaqus as Document, Document-1…to Document-4

So I tried to open the Step file in text editor to see where this “Document” name is coming form I found a line as shown below

So I tested it by changing this Document to Cube Test it works as shown below.

Now is it something I am missing!!.

Why the name when it is imported as step not showing as Cube Test A, Cube Test B,…Cube Test E.

Could someone please clarify.

Please find the attached Rhino & the Step file.

PS AP203 is the format i have used since Abaqus is compatible with this.

Thanks.

BR,

J.Randeep

9.0 Cubes.3dm (3.7 MB)
9.0 Cubes.stp (35.6 KB)


(R.Jaison) #2

Hi Again

The only work around I was able to achieve for this Abaqus Import Problem

is to export the different parts individually in Rhino by Layers and save them as step files with the layer name &

Import to Abaqus (in Abaqus the part name is take as the file name)

I found the following script on Developer page

https://wiki.mcneel.com/developer/scriptsamples/exportlayerobjects

I modifed the script to export .step as shown below

I am not a programmer so I no knowledge

  1. Now the file name is saving in the order “File Name_Layer Name.step”

How to modify this script just to save as “Layer Name.step” like as shown below

image

  1. With this current script when I run them in rhino it ask each time for the STEP Option depending on how many layers I have

Can we somehow have them in the script that it dose not ask it runs automatically

  1. is there a possible way only to save file for the selected object now it saving for all the layers that is in Rhino Model

Please find the attached the script & Rhino file.

Could some please help on this regards.

Thanks.

BR,

J.Randeep
Export Layer Object.rvb (1.3 KB)
9.0 Cubes.3dm (87.1 KB)


(R.Jaison) #3

Hi,

Sorry I just noticed it is not separating the object by layer name while saving the file it is saving all the object in all the files it is created.

BR,

J.Randeep


(Pascal Golay) #4

Hi Jaison - object names are exported as far as I can see - that is, re-importing a step file to Rhino correctly shows object names. So the question may be with the importer for Abaqus. I see that SolidWorks also does nothing that I can see with object names.

-Pascal


(R.Jaison) #5

Hi,

Thanks for the reply yes I agree there is something strange with the Abaqus.

With Ansys I tried there was no issue there.

But with Abaqus it seems it is some thing to do with the part name rather than the object name.

My second proposed idea will work. But the work flow would be much easier if there is a proper Rhino running script

That can write several step file with layer name as a file name with the specific layer name object s in that file.

I completely understand but at least this is workaround to solve this issue.

As my part name & layer name are the same.

I don’t know how this script for export objects with layer name as step file name works so to have several step file depending on how many define layers in Rhino.

I would deeply appreciate if you could look in to the previous threads and the point 1 to 3.

I have a feeling it is rather a simple script/revision to the existing attached script for someone with the Rhino script knowledge.

Thanks.

BR,

J.Randeep