My STL files are suddenly boxy instead of smooth?

Trying to export an object i modeled into STL file but suddenly it’s boxy and pixelated looking instead of smooth like the original. I was able to successfully export it yesterday and the day before the way it was. Not sure what changed, maybe I accidentally messed with the mesh settings. If so, how do I reset it?

The original is probably very far from the origin… If so move it closer and re-export.

If not, have a look at your export mesh settings.

1 Like

What do you mean by origin?

World origin - i.e. 0,0,0.

1 Like

Hi Mitch - meshes will only appear smoothish if they are welded - try Weld at maybe 90 degrees or so - any different?


I can’t seem to even use the Weld or mesh tool. it won’t let me click on the object. I think there’s been a setting change because there was no difference in actually modeling the object.

Can you post the file here?

messaged it to you! thanks

OK, your object is not far from the origin, so something must have gone wrong with your .stl export settings I would say.

I exported a test STL with the settings below and it seems fine (sent by PM).

1 Like

Hi Mitch - can I get this badly behaving stl file? I still don’t understand what the behavior is that cannot be fixed with welding or some other Rhino command.