My Meshes won't weld

Hi Guys,

My meshes just won’t weld. I’ve tried welding at 180, unifying normals, changing unit tolerance - Not sure what to do - I hope you can help?

Many thanks,

Arthur

weld.3dm (126.2 KB)

Hi Arthur,

Weld only works if the vertices are coincident within tolerance. If you zoom in closer you see that this is not the case. To Weld this mesh, check first that the normals are pointing in the correct directions, then join it. Unselect the mesh and run:

_AlignMeshVertices _SelectNakedEdges _All _Pause 0.1 _Enter

The _Pause in the macro is that you can select the mesh. This works only post pick, otherwise the _SelectNakedEdges option is not available. After this, _Weld 180 should work as expected.

c.

1 Like

Thank you so much Clement - I really wonder why the vertices were not coincident,I snapped with vertex…
Anyways it works really well now thanks again.

1 Like