Multiply cross section Loft problem in Grasshopper?

Hi everyone,

The “Loft” on the curve doesn’t seem to be the same at the top and bottom points on the cross-section, the vertical plane is twisted. I’m using the option “normal” for the loft command because I want the section to be smooth.

I tried to bake from Grasshopper to Rhino and use Rhino’s loft command and no problem.
so what is the problem? Thank you (12.6 KB)

It seems what you’re saying is just a display(coarse render mesh) problem… Try to increase the section count for loft. (5.8 KB)

1 Like

Thank you for your answer. I think it’s a method to increase accuracy, but the more points the model gets slower. The deviation still exists although small.
And when I export this Brep to Tekla, its cross-section still isn’t quite straight.

Hi Tung,

I opened your file and everything is ok.

if you bake the file, the geometry is as it should be. To display geometry in rhino and also the gh preview mesh is used, and therefor always a visible deviation. your geometry is good and your gh file ok (except for the useless sunion at the end, once capped its a closed brep)

Given the size of object you are designing, are you sure you really need the “Small-objects mm” template? will this be produced at 1/100mm? The display mesh will probably be a little better when adjusted, but at the end it doesn’t change the fact that your model is ok as it. Just “displayed shitty” when you zoom to 0.01mm

I don’t know Tekla, but if it works with mesh, it seems normal to me that you cant have a round edge.

hope this helps

Hi Benedict, Thank you very much for your explain.The deviation is small but it still directly affects the cross section when I output. I solved by dividing more points to increase accuracy.

But I just wonder why the section is curved and twisted between the 2 points when loft. I tried exporting the Brep to Rhino, you won’t see a problem with Wireframe mode but the problem will show up if you leave the view as Shaded or Rendered.

Picture for Rhino

Pictue from Tekla (Export brep to Tekla)

Hey Tung,

the “problem” with rendered mode and display in grasshopper is the same. both create a “display mesh” and project it to a plane (which is your screen) to have a flat view of a 3-dimenional volume.

for the import to tekla I can only imagine that tekla works with mesh or detects edges from mesh, or has also some mesh display properties. do you have import settings you can play around with?
however, please try the following:

  • create a file with smaller tolerance (e.g. cm or even m) and copy paste the volume to the new file.
  • make your model like 50 times smaller before the export and resize it in tekla.
  • try to extremely exagerate the mesh settings (even if it takes longtime) so you can find out how tekla treats imports.