Multipipe not working as should?

I am working on some complex multipipe structures, very powerful… when it works. Can someone have a look at this small script, I am trying to understand why the first image is not working yet when I snap it to the end as in picture 2 it seems to work?

Now sure why this is happening, appreciate any help
multipipe forum

multipipe forum2

In image 3 the desired result however why does this only work when the curves are individual?
multipipe forum3

multipipe.gh (17.9 KB)

Hi @w1743763
The Curves input is List access type.
So if a data tree is input here, it will make a separate result for each branch.
If you right-click an input you can choose the ‘Flatten’ option to turn your tree into a list so the curves are all processed together.

1 Like

Hi Daniel

Thanks for your help, I have tried this however it still shows up as an error reading > 1. Solution exception:One or more errors occurred.

Which service release of Rhino is this in?

1 Like

I believe this is rhino 7.3 or whatever the latest is I just updated a week or so ago

Hi -

Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

1 Like

Rhino 7 SR4 2021-3-8 (Rhino 7, 7.4.21067.13001, Git hash:master @ ed629035202f07e8b84a3ee211479ca20bb81b73)
License type: Evaluation, build 2021-03-08
License details: Stand-Alone
Expires on: 2021-04-08

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro M2000M (NVidia) Memory: 4GB, Driver date: 12-6-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.69
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel® HD Graphics P530 (Intel) Memory: 1GB, Driver date: 10-14-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2020
Driver Version: 27.21.14.5269
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\export_STL.rhp “STL Export”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Abanoub\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Hi -

I see that error here too when running Rhino 7.4. I don’t know in which version this was fixed - you might try changing your update frequency to “Release Candidates” to install the current public 7.5 build.
-wim

You might want to divide and shatter your input curves to get better definition.

@DanielPiker it would be nice to be able to choose the number of around segments.

multipipe.gh (13.5 KB)

Thanks can you advise a bit more on how to do this?

Hi Martin I have tried to explode the curves and didnt work either

Thanks

Hi -

Go to Rhino Options > Updates and Statistics > Update frequency and set it to Service Release Candidate.
-wim

1 Like