Multipipe generates wrong nodes

prueba multipipe Edited (14.9 KB)
I am trying to understand why multipipe generates the wrong nodes when I input curves into it in this case.

The right side in the picture:
The curves are generated by 3D Voronoi as closed curves.
I shattered them and removed duplicates.

The left side in the picture:
The curves fed into Multipipe are lines get from the curves of the right side case.

1 Like

prueba multipipe Edited (20.8 KB)

Problem solved. Just need to rebuild the curves before feeding into Multipipe.
But I still like to know why it didn’t work, if anybody has any idea, please share.


Thank you so much!
I was just copying what you did. When running the command rebuild curve, got me an error. Don’t know why. It says that conversion failed from point to curve
intento (26.5 KB)

Then, provide curves instead of points…

And if one day you want some other types of section, I have it on my plugin Nautilus or on some old discussion pages.

As it is now a paid component here I internalized the result. As you have a cracked :grimacing: version of Rhinoceros, not sure the paid component could interest you.

prueba multipipe Edited (11.6 MB)


Awesome Laurent! Love the plug-in! :star_struck:

PD: Don’t be so quick to judge others, some people offer those cracked versions as official versions and many people fall for it. Also one can never know the singular situation to each person that made them end up with a cracked version of a software. Many students, specially in developing countries can’t even afford 100USD much less 999USD.

Not justifying anything but I think its better if we just leave the moral judging and policing to McNeel and well, the police (although they probably have more important stuff to do).


You are right, I tried not to judge and yes it is up to McNeel to do this type of work. It was more a remark as you said some didn’t know they have a cracked version. I hope @Sebastian_Szmulewicz found my remark not too harsh.

1 Like