Moveface links object to dimension call outs so both change parametrically

unhandled

(Info) #1

Is there a way to have dimension call outs for an solid link parametrically other than through the moveface command? In an ideal world I would like to dimension a surface and if i move one of the surface’s face through using gumble the dimension call out would update as well. Thanks!


(John Brock) #2

Assuming this is V6, SolidPtOn lets you drag corners around and the history enabled dimensions update.
It’s not “parametric” because Rhino isn’t parametric.
In Rhino the geometry drives the dimensions, not the other way around.


(Info) #3

Hi John, Yes V6. I tried the command solidPtOn and the dimension lines followed once out of 4 tries. Seemed random so i must be missing something. Maybe its your comment about history enabled dimensions. Can you elaborate? I know that Rhino isn’t parametric but i wasn’t sure what word to use to explain having the dimensions follow the geometry changes.


(Wim Dekeyser) #4

It would be more useful if you could post a specific example (i.e. 3dm file).
The position of the dimension is only partly “linked” to the geometry that it describes. The value, though, should always update when the geometry is changed.


(John Brock) #5

I suspect you are starting with a lightweight extrusion object, dimensioning it, then making a change that requires Rhino replace it with a polysurface. Then the link to the dimensions is broken.

If you start with a polysurface first, then it should just work.


(Info) #6

I started with making a solid. The solid being rectanglular in shape. I then dimensioned the width and depth. The dimension points were at the outer corners of the solid. I then changed to top view, pressed ctrl + shift, grabbed one end that was dimensioned, pulled it with the gumble. The solid changed as per how i pulled it but the dimension stayed in its original place and did not follow the solid. Like i said before it was really weird because it did follow one time when i tried it after i’d put in the solidPtOn but never again. I’m not sure if i am using the solidPtOn command correctly.


(John Brock) #7

That’s what I thought.
Draw a box. Notice that it does not have isocurves on it’s faces. It is an extrusion object.
You can check this with Properties.
Turn on it’s solid points and drag one corner. Notice that now the faces has isocurves? Now it’s a polysurface.
The visual clue was the display of isocurves in Wireframe and Shaded display.

Consider running the UseExtrusions command and change it to use polysurfaces.
Then the object replacement I mentioned that was breaking dimension history will not happen.


(Info) #8

That is really cool. Is there a dissadvantage of always using polysurfaces instead of extrusions? For the dimension history to happen does it only work with polysurfaces. The reason i’m asking is that i’m considering using visualarq to create Make2d sections of the model which apparently will change if the model changes. Then dimensioning the resulting 2D section in model space instead of paper space. So if there are changes in the design not only does the 2d change but the dimensions will follow suite. Cheers


(Wim Dekeyser) #9

They were introduced in Rhino 5 to try to speed up the display of vast amounts of simple shapes. So, the only reason to use them is if you have a huge amount of simple “boxes” in your scene (e.g. an entire city of very simplified buildings). I’m not sure if the benefits of speed still apply in Rhino 6 though.

No.
Dimension history also works for lightweight extrusions. If you e.g. use Scale1D to make a box wider, the dimension will follow. When you edit the extrusion in other ways so that they are “converted” to regular polysurfaces on-the-fly, dimension history is destroyed. The conversion deletes the object that the dimensions were linked to and the new object doesn’t inherit those dimensions. I suppose that could be considered a usability problem and should be fixed - but then again, an extrusion object is really a special object that generally shouldn’t be used and also others have advocated in the past that the default of UseExtrusions should be to use polysurfaces.

I’m not sure what you are saying here…
It doesn’t matter if the dimensions are in model space or paper space. History works for both.


(Info) #10

Thanks for all that info! The last point i was thinking about is when the Make2D command is used. The output from the Make2D are curves, i think. So i know that i can dimension the result of make2d in model or paper space. However with VisualARQ apparently it does something similar to the Make2D command and the result is linked to the actual model. if the model changes so does the Make2D command. So i’m wondering if the make2D result changes, will the dimensions change the same way they do for polysurfaces?


(Wim Dekeyser) #11

This is one for @fsalla to answer.


#12

@Info, you can add dimensions to VisualARQ section views (what you call “Make2d sections”) after creating them, but they won’t change when you update the section views. Unfortunately dimensions can’t get linked to VisualARQ objects so far although we have plans to add this feature.


(Info) #13

Thanks for the info. Is the reason the dimensions won’t change is because the output is not a polysurface?


#14

The linked dimensions either in R5 as in R6 are using the “record history” in the background (if I’m not wrong), and only can work with certain type of objects (not with VisualARQ’s) and with certain commands.