Move group from a known point to a "named" point

Hi Group

I have imported a step file of an assembly and I need to locate it over a specific position on some curves I have drawn.
However, once i select the “FROM” point the group of parts sticks to my mouse waiting for the “TO” point
but because my “FROM” point is in the cluster of parts it is really hard to see anything and i am unable to pick up on my “TO” point as i can’t clearly see it?

so i set a point where i want it to land and named the point “pointA” and i was hoping just to type in the named point but this won’t work…
is there any way i can type in or select a named point for the “TO” point?

Hi Adrian -

Not without a script of some sort.
Does your “cluster of parts” include many point objects? If not, you’d use the Point snap to snap to that TO point without having to be able to visually identify it.
Typically, I just make a temporary line between from and to, and move that well out of the way of things to move so that it’s not buried in a lot of geometry.

1 Like

Thanks Wim,
yes this makes sense and works (it’s what i did in the end) however it would of been great to move to a named point.
which could be handy when messing around and trying things in different locations…
perhaps one day it wil be possible.

Hi Adrian - you can try this - (1.4 KB)

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"

@adrian updated/fixed… let me know…


1 Like

Hi Pascal
thankyou for your reply, file and input…
however, it is not working in rhino 7 this is what happens:

  • i run the script
  • it asks “select objects to move”
  • i select my group of objects and press enter
  • a window pops up called “named points” and my named point for the “to point” is in it so i select it and the window disappears
  • it asks “point to move from” so i select a point on my group of objects
  • nothing happens and it said “Invalid move vector”

I think it should ask from point first, and then the window that pops up with the named point should say “select to point” ?

regards adrian

hm, well it is a quick and dirty script but it worked here… let me have a look.
Oh, yeah, I did post a busted version, hold on.

@adrian fixed above, sorry about that, missing a “()”.


1 Like

A suggestion.
I would love to use named points in a similar manner to using “0” as a shortcut to the global origin.

For example, if “B” was a user-defined coordinate. A line could be drawn from “B” by pressing keyboard B at Start of Line prompt. Similarly for any other command that needs a selected coordinate.

One specific tedium is when the required entity is out of the View. There is a lot of zooming out, then zooming in the other side of the model to find the correct point - especially when the design is crowded.

For me, 5 letters reserved for custom coordinates would be sufficient.


1 Like

Hi Pascal
that works great. Thankyou!
I think it should go on your wish list to fit into Rhino proper, as it is a very handy tool :slight_smile:

Out of interest, I know a small amount about python and have dabbled with learning but time always gets the better of me, however, i need to start learning it.
once i get the basics is it easy to then pick up and learn for use in Rhino?

regards Adrian

Hi Adrian- here are some helpful links


1 Like

Thankyou Pascal.