Move face command messes up clean surfaces

I run Rhino 6 and have come across this issue recently with moving faces. It’s never been an issue before so I’m confused as to why this is a new problem. When I move the face of a surface, it totally messes up the geometry of the whole surface.

The closed polysurface on the left (after) is after I move the face highlighted in blue on the right (before) polysurface.

Any help or ways I can solve this issue and keep my polysurfaces clean would be great. I’m also finding that mergeallfaces isn’t working as well too. I can snap to existing points and make a clean shape and the mergeallfaces will still not produce a clean polysurface.

Thanks in advance!

Hello- yep, indeed - this, and sub-object selection and moving is often not the best thing unless you are dealing with all planar faces, and even then it is limited.
That said - can you export that object to a new file and post it here?


desk backing.3dm (6.2 MB)
Hi Pascal, Here is the isolated object.
I’m not new to Rhino and have been using it for 6 years now…So I’m wondering why this feels like a new issue over the last week or so. Thanks in advance for your help!

Hello- see how this works -

desk backing_PG.3dm (6.3 MB)

I did two things:

  1. DivideAlongCreases with SplitAtTangents=Yes, to split off the planar from the non-planar parts of that outer face.
  2. The outer face that has the rectangular trim appears to be microscopically not planar - I need to look into this - but I extracted and SetPt that face in Y and joined it all up again and it seems happier.


Thank you so much, Pascal!
It’s definitely happier. I’ll be careful to make everything planer moving forward.