Missing objects for attached DWG

I am trying to attach a DWG to Rhino, but some of the objects are missing. When I try to open the same file in Rhino the objects are there.

Is there some hidden setting that is messing this up for me?

Kant.dwg (739.7 KB)

Hei Anders -

When I open or import the DWG file, one object and 3 block definitions are created. No block instances are created.

When I attach the DWG, only the object is created. Unused block definitions are not imported.
If the DWG file has instances of a block definition, both the instance and the definition will be imported when that file is attached.

Is that what you are seeing?

Hi Wim Dekeyser

The blocks in the file is a relic of an AutoCAD extension that the person who made the file have. The only object I am actually interested inn is the 3D solid in the “3D_J_Kantstein-vis-13_NStone01” layer.

In reality this is part of a bigger file with many 3D solids, but this is the only one that is not converted in Rhino. The other works fine. In the original file there are multiple 3D solids in the “3D_J_Kantstein-vis-13_NStone01” layer as well.

I have attached a bigger part of the original file. Kantstein_temp.dwg (2.2 MB)

Hei igjen, Anders -

But that one object does get into Rhino, both when you open or when you attach the DWG file, no? I’m not sure I’m understanding the problem here.

It does when I open the file, but not when I attach it. I need the geometry form the file for placing equipment next to the road, and need all the geometry to be able to place it correctly. I can copy it over to the file I am working on, but if this keeps happening in other places I rather find out what is causing it so I can avoid having a lot of help objects in my work file.

Anders -

That’s not what I’m seeing here.
I drag-n-drop the DWG file onto a new Rhino document and pick “Attach file” from the “File Options” dialog:

I then confirm the DWG settings and, when the file is read and I zoom to extents, this is what I see:

Is that not the result you are getting?
Please run the Rhino SystemInfo command and copy-paste the result here.

That is strange. in the big file it looks like this:

Rhino 7 SR12 2021-10-26 (Rhino 7, 7.12.21299.13001, Git hash:master @ e5af0da40b6862372c535b6d480b5b383a62f317)
License type: Commercial, build 2021-10-26
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 10-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.39
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-13-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\AajtRhino (38dd954a-7958-4163-905f-53434e649109)\\net48\AajtRhino.rhp “AajtRhino”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21299.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21299.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21299.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.12.21299.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21299.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.12.21299.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21299.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

This is with the bigger file on my system:

Your picture doesn’t look like it is zoomed to the extents of the scene. Could you post a picture of the perspective viewport zoomed to the extents?

This is where the curb is missing.


Opened directly:

Hei Anders -
That is strange, yes. I am running an internal 7.13 build but I cannot find any YT issues that would explain the difference with your 7.12 build. Could you please disable the AajtRhino, Tibidabo, and VisualARQ plug-ins and restart Rhino. Then attach that DWG to a clean Rhino file from a factory-default template. Does that make a difference?

I tried to deactivate all plug-ins on my machine, but it did not help. We also tried to install Rhino on a different machine, and it worked correctly there. We even installed all the plug-ins on it and it still worked. It its odd, because the 2 machines that have had Rhino for months have the same problem, but not the new install.