Trouble attaching dwg. with blocks in Rhino 6


#1

Hello. I found a problem that wasn’t present in Rhino 5. Whenever I try to attach a dwg with block definitions I get the message: “A block definition named:“Drawing_name.dwg: Block_name” already exists.” I tried with just one block and after I press OK it attaches but for drawings with hundreds of blocks this becomes a problem. A workaround I found was to open the dwg, save it as a rhino file, and attach that.


(Ha Paris) #2

Hello same trouble here.
image
Many blocks in the attaching file and for each block one pop up error like that.
I have to crash Rhino 6 to stop that.
No problem in Rhino 5.
Pretty disapointed about that. We use a lot attaching dwgs and worksession with dwgs here.
Many thanks in advance to find solution to that problem.


(A&S) #3

I can second this issue as well with the rhino nested blocks. When I open a R5 version of the file with nested blocks in R6, then I get the same error message. Somehow the block (specially if nested) are not updating/registering if they are linked blocks.


#5

Hi All,
I have the same issue. Is there a way to suppress this warning?


(Ha Paris) #6

This is working well now!
I guess the last update resolved this trouble.
Many thanks Mc Neel team!