Middle mouse to pan doesn't work

this is not working for me. nothing happens. can anybody confirm its not working

Mac Version 6 (6.19.19298.01152, 2019-10-25)

This doesn’t work for me either.

I normally have the middle mouse button set to Popup this Toolbar: Popup (works fine).

When I set the middle button as shown above by yousef.k the middle button has no effect.

Rhino for Mac Version 6 (6.20.19302.09472, 2019-10-29)

_SystemInfo.txt (3.1 KB)

It’s working for me in 6.19, using a USB mouse.
I had to Quit Rhino and restart for the change to take effect.
Press and hold the zoom wheel and I can Pan in Parallel projection views and Rotate in Perspective.

That’s weird.
Now I can’t switch mine back to the Popup menu.
I’ll Buggify it.


I tried a USB mouse (I normally use a Magic Mouse) and the middle button works for panning.

Still something odd though. I cant get it to rotate with the middle button. If it click the setting for Rotate there is no effect. If I select Rotate then quit and restart Rhino the setting reverts back to Pan.

The settings for Popup Menu, Popup Toolbar and Run Macro all take effect as soon as they are selected (don’t even have to close the preferences window).



i tried to restart, it still doesn’t work. i am using a usb mouse as well. it used to work on version 5.

@John_Brock can you please bug this? unless you already have. thanks.

Hi Yousef, you can see a few posts up that John filed the bug report.

sorry i thought he bugged his problem.

Hello - it is a bug report but at the moment we’re having trouble reproducing it - it does appear that the Rotate setting is broken however…


Hi pascal, how can i help? by the way, i just tried to edit the setting and restart rhino. and i noticed, now the option is greyed out

Rhino 6 SR19 2019-10-25 (Public Build, 6.19.19298.01152, Git hash:master @ 01a413724f36af3118af8e0ad5305b6671ef66be)
License type: Commercial, build 2019-10-25
License details: Cloud Zoo. In use by: Yousef K ()

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G103) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro13,3
Machine name: Yousef’s MacBook Pro
Language: en-SA (MacOS default)

AMD Radeon Pro 460 OpenGL Engine (OpenGL ver:4.1 ATI-2.11.20)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: AMD Radeon Pro 460
Displays: Color LCD (258dpi 2x)

Graphics processors
Intel HD Graphics 530 (1536 MB)
AMD Radeon Pro 460 (4 GB)
Color LCD (1680 x 1050)

USB devices
Razer: Razer DeathAdder Elite
Apple Inc.: Apple T1 Controller
Sound Devices: USBPre2
Apple Inc.: USB-C Digital AV Multiport Adapter
Apple Inc.: USB3.0 Hub

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.19.19298.1152
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.19.19298.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.19.19298.1152

I found the problem and am working on a fix.


I just tested the fix in an in-house developer build.
The fix will be in release 6.21

Awesome! You guys are the best!!!

1 Like

RH-55461 Preferences: Mouse preferences not sticking

should now be fixed in the latest Release Candidate for 6.21, which is available now for testing.