Metahopper enable/disable component does not work smoothly within cluster

Hi all,

This is my first post. I am working on my thesis in structural engineering. For that, I am modelling different geometrical configurations for buildings. For example, all the possible options for the vertical elements, are located in a cluster. There, a stream filter eventually selects the system chosen to create the output outside the cluster.

Because the script for creating the geometry is quite big, I want to disable the components that generate the geometry for the structural system not selected.

I tried doing this, by using the disable/enable component. It works as shown in the photo, by providing the input from the value list outside the cluster, the the equality component. If that number matches, the objects selected will be disabled (dont mind the stream filter and the toggle, that toggle is just for convencience, removing them wont change the issue).

When I am inside the cluster, it works the way it should be. However, back to the normal canvas, it does not. If I then change the structural system selected in a value list, all the output from the cluster dissappears. You have to manually enter the cluster again, and then it works again.

But going back and forth between the cluster and the canvas everytime when I change a stability system, is not desired, and I am afraid it will lead to problems during optimization processes.

If anyone has a solution on how to make it possible to disable certain components inside a cluster, based on true/false statements from the canvas, without having to double click the cluster and enter it again, it would be much appreciated.



You could use a stream filter to only send data to downstream components when the input is true…

1 Like

Yeah, I was thinking about that too.
Are empty components as good as disabled components regarding calculation time? Cause that is my goal mostly.


1 Like