Meshing of closed Brep in Grasshopper creates transparent Mesh

I have the following problem when trying to create a mesh from a closed Brep, created using a 360° Revolution of a closed polyline:

When I bake the closed brep from Grashopper to Rhino and insepct it, all seems fine (see following two screenshots)…

Closed Brep Desc

If I now use the “Mesh Brep” Function in Grasshopper and bake the results, the Mesh looks strange / half transparant even tho the details say it is a closed valid mesh:

Mesh GH Desc
I tried unifying the normals and welding the mesh, but with no vsible result.

If I do the meshing in Rhino and not Grasshopper, everything works as expected:

Do you have any idea, what could cause the meshing in Grasshopper to create the shown results? In other situations the meshing in grashopper works fine, it only appears with my brep created by the revolution of a closed polyline…

When meshes are valid but look like that, it’s usually flipped normals. Grasshopper shouldn’t be creating meshes like this, but you can probably avoid it by either reversing the direction of the curve before you revolve it, or just flip the resulting mesh.

1 Like

Thank you very much, flipping the curve before the Revolution worked for me :+1:

1 Like