Mesh SettingsCustom for MeshBrep in Python

How can the Mesh Settings, defined one line above, be applied to the next line for MeshBrep? The print idenifies it properly as MeshParameters but the MeshBrep is not getting it!

I tried any possible definitions, but am not able to get any custom settings applied via Python. It constantly throws the failed from Goo to MeshSettings Error on me. There is no “coerceasmeshsetting” around, isnt it? How can the MeshBrep command be used at all with that problem? (8.2 KB)

Hi, you may want to use RhinoCommon for this like suggested by Anders here:

Thank you Alain! I actually tried that already and it works ok, but the problem is that it seems not to be “thread-safe” and as I try to get this meshing working in a parallel pythonloop, its not working in parrallel unfortunatly, I really wonder how to apply these settings directly. The commands are there so there must be a way.

Otherwise it would mean that the ghpython implementation of the MeshBrep is not usable at all. I have a hard time to imagine that this could be the case.

…also I tried to define the meshsettings with the Rhinocommon class first and then apply it to MeshBrep, but it throws the same error. The command itself seems to not understand “MeshingParameters” at all…

What exactly isn’t working? What error is being thrown? And how did you implement it?

Its the same Message as before. “failed from Goo to RenderMeshSetttings”. I tried several other examples from this forum where people replied its working now but actually it is not anymore for some reasons.

The example here is not working with my version of rhino 6:

I get the same message as in my own example while some was replying that it worked.

So the example file I posted that Alain linked to above is also not working on your system? If so, that smells like perhaps a botched installation or something along those lines.