MeshBrep component and Custom settings component

Mesh Brep components often do make strange things for me. On the image below I use Mesh Brep component and plugin Settings (Custom) component. Even though I have set the Max Edge limit to 22 mm eventually I have got mesh with an ugly long edge of 125 mm. How is it possible? Why custom settings don’t restrict the max length of the mesh edges?
Also, I should say that I try to apply custom settings for the Mesh Brep component since the default setting and Smooth setting get the same result with this long ugly edge. But if I run Mesh command for Rhino the mesh result is much better