Memory Issues

I’ve experienced this problem many times before, with Rhino 6 and now 7 where it seems even worse. I have a very large GH file, about 450 MB, but in this instance, its just components containing meshes. The solver is disabled. as are all the components themselves. If I so much as drag a slider on the canvas, my memory goes into a fit and that little circle whirls for at least 10 minutes. What is going on, and how can I speed things up, if possible? I’ve got 16Gb memory BTW.

There’s no way to know without checking the file, sorry. If the file has a reasonable size and you can have us look at it, you can sent it as PM to me.

Otherwise, one way for you to approach some checking, would be some “divide and conquer” approach. Start by creating a copy of the file, then deleting the left half. If the problem goes away, then it was on that side, otherwise, delete the other half. Repeat till you find the worst offender.



Giulio Piacentino
for Robert McNeel & Associates

Disable the AutoSave from Properties and problem solved. :+1:


Thank you Dani! I wish I had posted this question quite a while ago! Disabling Autosave did the trick.
I could have taken a couple of weeks off with all the time I’ve spent waiting for my memory to calm down.

Giulio: the reason I was mystified in this case was because nothing should be happening. There were no components that did processing and everything was disabled. Just adding a slider that was connected to nothing sent memory into a frenzy…

1 Like

This sounds like something we must fix.

@Dani_Abalde, @akilli do you mean the Grasshopper AutoSave?

Yes. That long delay also happens when saving the file. I think you can reproduce the problem internalizing 100MB of meshes in GH, if not, keep trying playing a while with the definition. With the autosave active and its options as default, you should encounter a long delay when connecting or disconnecting a wire.

Do you mean with the big, internalized mesh? Then that’s expectable, because you are saving the file after all… no?

Well, it means that serialisation is quite slow. And if it can’t be improved, it would require a more intelligent serialisation that instead of overwriting everything again, is aware of the parts that have changed to only write that, if that is possible.

Like I said above, I was mystified because they were just meshes. Apparently anytime you do anything with GH Autosave active it, well, Autosaves. I had no idea that’s what was happening all this time with my large files. Thanks again to Dani for pointing this out.

1 Like