Empty Rhino+ Grasshoppers take too much space and block the computer, high usage of memory

Hello folk,

Empty Rhino and Grasshoppers are taking too much space and Use the whole Memory of my computer. (please see attached

Did anyone faced the same issue?

Thanks in advance,

Hi - you haven’t provided more specific steps to reproduce this so I launched Rhino (6.23.20014.20381, 01/14/2020), then ran the Grasshopper command and then checked the task manager for memory consumption over 60 seconds. On my system, there is no increase at all.
Do you still see this when you reboot your PC, launch Rhino in safe mode and then run Grasshopper?

thanks a lot Wim, yes I reboot my laptop and I am using Rhino 6, the memory usage increases way more when I ran the grasshopper, even if ‘lock solver’ mode. I need to mention that nothing else is running in my pc parallelly.

Hi -

  1. did you try it in safe mode?
  2. you didn’t mention opening a specific definition in Grasshopper, so why would “lock solver” mode do any difference?



ops, it’s just my habit to lock the solver first before opening any file, but anyways there is no doc opened. And the safe mode is not helping either :frowning: any other option that might help?
thanks a lot

Hi - can you post your SystemInfo?

Does the memory usage increase (visibly on the taskmanager) when rotating the viewport when using a Custom Preview component in the GH definition? If that is the case I experience a similar problem, shown in the following gif:

// Rolf

Hei Rolf - I had your report in mind but in this case it appears to happen without anything at all loaded…

yeap, as Wim said. Nothing is loaded … and the it worked normally few days ago.
Since then no change was done in the computer :confused:

You didn’t provide the SystemInfo?