Material drag&drop

Just as some related feedback here, Nathan. In an example that was posted here a few days ago [climber_skeleton_forces], I was trying for a while to assign the mesh vertex shader to all selected objects by dragging and dropping the material onto the objects while in a Raytraced view. That was just impossible - there wasn’t any response from the application.

I then went back to the video that you posted in that thread and saw that you right-clicked in the material. That worked.

Quadro K3100M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 385.90)

Hmm, I indeed have learned myself to use RMB in material editor for assignment. Drag and drop should work, but during dev this was a lot in flux (underlying pipeline, not Raytraced) that it didn’t always work. I have to test current status…

How do you drag and drop a material on all objects at once? I at least cannot drag&drop a material on a selection even in Rendered mode. The selection always changes when the mouse moves over the objects to the object currently under the cursor.


p.s. split off into new topic.

Well - that’s part of the point. I was expecting that to work when several objects were selected at the same time.
I found out that you can’t - but trying that in Raytraced first was a strange experience. (;

Nice to know you were in Raytraced to begin with :wink:

I don’t know if this is supposed to work. I must say I would expect as much, but maybe @pascal or @BrianJ can tell us more about what the expected behavior is here.

1 Like

Hi @wim Drag and drop works on meshes while in Raytraced here for me so post the file please or share with me through a PM and I’ll check on that one too. If you want to drag and drop to multiple objects in unison they need to be grouped first.

That’s what I was trying to do - but on multiple selected objects that are not grouped. I’m not sure why that shouldn’t be possible.

Here, if I have multiple selections that are not grouped and I drag and drop to one of them just that object would highlight and get the dragged material. You mentioned…

So I figured you weren’t even seeing one object highlight. Was that the case? If so, can you share the file so I can test to see if it is geometry related or system specific?

I believe the logic was that maybe you have a bunch of selections but only want a material applied to what you drag to. @andy can say for sure. The Group support for drag and drop or the RMB ‘assign to selection’ should work though for assigning to multiple objects so let me know if not as well. Thanks.


It was posted here:

Thanks for the file. I get an object highlight when dragging and dropping a material so I wonder if the issue of the meshes not highlighting during drag and drop is GPU specific. @jeff Do you have a Quadro K3100m to test this with?

The file as you uploaded it won’t show the vertex color material until the skylight is enabled. Click Reset to Defaults on the Rendering panel.

From what I can understand from this thread, you cannot drop on pre-selected objects… Drag-n-drop is itself a “selector”, which means anything that is pre-selected prior to the DnD operation will immediately be unselected. If you have something selected and want a material assigned to it/them, then use the Right-click menu on the material and “Assign to objects”.

If you don’t have anything selected, and you cannot drag-n-drop a material on something, then that sounds like a bug and I need to look at it… and I need an example… There is mention of mesh objects not being supported, but I don’t see that here… I can drag and drop a material as expected here…

So, if there is a case where this isn’t working, then I need:

  1. A sample file that’s showing this problem
  2. The display mode(s) where this isn’t working exported and .ini file(s) posted
  3. Step-by-step instructions on what I should be dragging and on which object I should be dropping.


I would rather say that it’s machine specific. Again, whenever I start Raytraced, the entire supplication becomes unresponsive. Actually, when I tried earlier today to do some more testing with materials, it was clear that all programs became unresponsive.

Back on my machine now. By switching to another display mode and checking what is supposed to happen, I did get this to work. But I have to be careful to select the material in the material panel and wait a while before dragging it into the workspace. A tooltip (“Copy”) will eventually show - lagging a way behind the mouse pointer.

So, does this work? Technically, yes. But it’s not functional on this machine. I’ll live…
wim out…

Ok, I understand now… This is DnD in a Raytraced viewport only… I too have seen this jumping, jittering, and hiccuping when trying to drag a material off of the material panel while Raytraced mode is “running”… I think it’s mostly due to bogged down CPU issues and/or performance issues in the managing of the raytraced mode and OpenGL code used to process the drag and drop information… I have also found that sometimes the mouse-down event on the material is completely missed, which results in me dragging nothing…

Note: None of this has to do with GPU specific features or issues…other than perhaps this works better on faster GPUs… but from a functional point of view, this should work on any GPU.

I’m not sure what to suggest atm…other than if you want to drag and drop while Raytraced is running, I would take things slowly… Left-click, hold for some period of time, then slowly start to drag…

In the meantime we’ll look into improving the DnD performance and functionality.


1 Like