Many issues with Cycles and clipping sections

finally I bought a powerful workstation with two RTX4090 gpus and I’m testing the final release of Rhino 8.
1st Is not possible to select 2 gpus for rendering. Why? I remember it was possible in the WIP releases. Blender can use multiple gpus…
2nd Using Cycles the clipping section feature doesn’t work properly excluding some objects from the cuts
3rd Clipping section clips the lights!!! Hey, why??? Some lights will disappear from the screen and you have to figure out how to bring back them on the screen again. Please avoid clipping lights from this tool.
4th Tweaking light power doesn’t work well in realtime within Cycles, it’s faulty.
I’ve found a lot of other issues and I will post new videos.
I think you must check all realtime feedback with Cycles on. Tweaking materials, objects, lighting and other stuff Cycles doesn’t update in realtime, it’s a random behaviour. I have to switch to shading then to raytrace to update Cycles.
Also rendering Cycles + wireframe isocurves doesn’t work well. Lines are horrible with low antialiasing, neither the Nvidia denoiser can fix this issue.

My Systeminfo:

Rhino 8 SR2 2023-12-12 (Rhino 8, 8.2.23346.13001, Git hash:master @ dbefe46c12cda06610a9ab683a211aa3d16f0030)
License type: Valutazione, build 2023-12-12
License details: Cloud Zoo
Expires on: 2024-03-02

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 1.3e+02Gb)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 4090 (NVidia) Memory: 24GB, Driver date: 12-6-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.33
> Accelerated graphics device with 8 adapter port(s)
- Windows Main Display attached to adapter port 0

Secondary graphics devices.
NVIDIA GeForce RTX 4090 (NVidia) Memory: 24GB, Driver date: 12-6-2023 (M-D-Y).
> Accelerated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 24564 MB

Rhino plugins that do not ship with Rhino
C:\Users\gabriele\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\IntelDenoiser\0.6.7\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\gabriele\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
d:\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.2.23346.13001
d:\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
d:\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
d:\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
d:\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
d:\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.2.23346.13001
d:\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.2.23346.13001
d:\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
d:\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.2.23346.13001
d:\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.2.23346.13001
d:\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.2.23346.13001
d:\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.2.23346.13001
d:\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
d:\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
d:\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

RH-77275 Multiple GPU support needs to be added for Cycles

RH-65805 Support selective clipping in Cycles

This is no different in Rhino 7, do you mean you want the clipping plane to avoid clipping them from view? What if you clip a room with ceiling lights and you look down? I suspect you don’t want these lights to be visible. Clipping planes affect a view you select and can be limited to objects as well as you know.

I could not reproduce that here in an internal build.

Yes, if you mean the post effect, those lines are horrible indeed and apparently there is no way to fix that. Better if you need these lines is to render through ViewCaptureToFile.

Probably because there were some changes for 8.3 that aren’t in 8.2

I don’t see the point to clip the light icons. I could move all the lights in a dedicated layer to eclude it from the cut but I will never cut the lights. Does anybody print the light shape or needs to have half cut of them?