Manual load of plugins not working


I disabled some plugins for loading, but I want to manual load plugins during a Rhino session per RMB click on the plugin name in the plugin manager and “load plug-in”. But Rhino tell me “blocking plugin …” always. Looks like a bug or? For example I tried it for Octane. (Permanent enabled loading is working.)


Hi Micha,
If I were to load plug-in with the RMB command right now on Brazil for Rhino it wouldn’t load because I haven’t checked the box. Sorry for my paint skills.

Edit: This is the way Rhino has worked since I’ve used it. I think it’s intentional…

Manual load should work like seen at my screenshot here, not permanent per flag option, temporary per RMB menu.

I don’t recall it working that way in years. But perhaps it’s been a while.

Edit: “in years” was meant to say “in the years I’ve used Rhino.”

Micha- the plug-in does need to be enabled to load- I don’t think it has ever been otherwise, has it? I don’t know if that is possible, to ‘Load just this once’…I’ll ask- but at least the Load Plug-in item on the menu should be grayed out or it should tell you it will reset the check box, something like that.


OK, than it could be great if the RMB menu entry could be intuitive used and allow to load a plugin during a Rhino session. The check box is controlled by the load protection entry. At the moment the “load plug-in” menu entry is without function and if used it cause a reaction that looks like a bug only.

I actually think it’s clearest to allow the plug-in to load once by using the right-click menu. Right now, that doesn’t work - but if it did, it’d require no additional UI or explanation about how to allow a one-time load.