Major problem: STEP import in V6 SR1 misses objects

We are finding that the STEP import in V6 is not thorough, and does not import objects that are there, and do import into V5. I can send an example to test. Just tell me where to send it.

This is a show stopper for us.



Hi Dan - I believe this is fixed here in the latest - send me the file and I’ll check it.


Hi Pascal,

It’s on it’s way to your inbox.



I’m having the same issue, but V5 had a lot of trimming errors when importing so I had to take the scenic route via Step > Fusion360 > Iges > Rhino V6.

Pascal, when do you think that build with the fix be available? Thx


I made the fixes to this in SR2, which I think is already available as a release candidate.

Yes the SR2 release candidate is available at

We are hoping to ship the final SR2 tomorrow if all goes well.

Thanks Steve. I did try to install RC4 but it’s looking for the redistributables and for some reason, I can’t download them. I do have internet access.


I went through this earlier today when installing V6 on an older system without internet access. I followed the instructions and was able to install. I’m not sure why I can’t do this on my computer. I will wait until the official release tomorrow and try again.



This is probably something for @brian to look into.

I found and downloaded the Microsoft Visual C++ 2017 Redistributable (x64). I ran it before running the SR2 installer, and the Rhino 6 SR2 RC4 installed without issue.

The STEP issue appears to be solved.



1 Like

The redistributable bug is fixed in the current SR2, which is now officially released.