Mac Rhinoscriptsyntax ExplodeHatch always returns None

I’ve been trying to explode a hatch into curves and I haven’t been successful yet. The script works fine on the Windows version. Any ideas? I’ve tried a little debugging. AddHatch creates an object. IsHatch returns ‘True.’ I can explode the hatch from the UI, but command(’_Explode’) also doesn’t work.

This is pretty odd… If I create a hatch first manually and then select it in a script with rs.GetObject(), rs.ExplodeHatch works. However, if the hatch is created via script, it does not work, even though the object ID seems to be valid. Don’t know what’s going on there, not enough debugging tools on Mac to dive deeper into that one. Works as advertised on Windows.

And - looks like you brought to light a second bug here actually. There is a missing argument in ExplodeHatch() in (on both platforms); you will see it if you set the delete argument to True. You will get an error message that “Delete() takes exactly 2 arguments (1 given)”.

@Alain - can you look at both of these? The second is an easy fix, but I don’t know what’s happening with the first.


Hey, thanks for confirming that this is a problem beyond my install. I’ll be interested to see what the outcome is. I had another issue with OffsetSurface today. Again, it works fine in Windows, but fails in Mac. I don’t seem to recall having this many issues with the WIP versions. They just worked. But something has changed in the RC versions perhaps?

Definitely a few problems here. Thanks for reporting