Lunchbox ExcelReader component not recognizing files

Hello guys!
I’m having some trouble linking any excel file to the lunchbox excel read component. The data output says null. It was working just fine until now. I have tried uninstalling and reinstalling it but nothing seems to work :frowning:
If anyone knows what could be going on, it would be really helpful. I’m attaching an image of the definition.
Thanks!
help

Hi Mariana,

Did you try specifying the worksheet ? just in case, I wrote a c# that does the exact same thing as that component, in case you needed a life saver

ReadExcel.gh (8.2 KB)

You will probably get an error messege becasue the .dll file I referenced inside the component has the file path in my pc. To fix that you will have to right click on the component —> Manage Assemblies —> Add —> C:\Windows\assembly\GAC_MSIL\Microsoft.Office.Interop.Excel\15.0.0.0__71e9bce111e9429c\

select the file named Microsoft.Office.Interop.Excel.dll It should be the only one in the folder.

After that everything should work fine

1 Like

Hi Nicholas! Thank you so much for taking the time to do the C# for me. Unfortunately, after I found the .dll file, I tried adding it, and then turned the toggle to true but the component didn’t run.
I did specify the worksheet but still couldn’t get the excel reader to read my file. I really don’t understand the problem since it was working perfectly until now :cry:

Can you connect the out to the panel? so I can see the error messege?

Yes, of course

Are you sure your worksheet name is “1”? Usually it’s “Worksheet 1”

https://docs.microsoft.com/en-us/office/vba/api/excel.worksheet

Thats not the problem (; it runs in my pc just fine

Is your computer 32 or 64 bits? in mine it runs fine, I have a 64 bit computer

It’s 64 bits! I have no clue what the problem might be then :confused:

Thanks anyway!

lol … Ok, thats to bad… sorry ):

1 Like

Hi,
here’s my workaround for solving this problem:
It seems to have something to do with your system remembering older versions of excel or having already established connections, that are not existing anymore.
so, since I was establishing a new user profile in windows, installing rhino+GH+addons there, the connection is working - of course just in this profile.
It is not the most elegant solution, but it is one …