Excel reading errors

Hi All,

I have been having some rather frustrating ikssues with reading excel files. This is happening with both Lunchbox and TT Toolbox; it is relative new as previous scripts I have written work ok. A couple of my colleagues have tried the same script and excel files with no issues. I have tried reinstalling lunchbox but having the same problem still.

Just seeing if anyone else has had this issue? It has been very frustrating - I have uninstalled and reinstalled lunchbox numerous times however I am yet to fix this issue.

Any thoughts or help much appreciated

Cheers

the input is sheet number not the file path
note open excel file works

HI Rajeev,

Thank you for the mail, I have the path correctly connected to the path field and the worksheet toggle left blank for the default sheet1. I think the issues is to perhaps under the hood (i.e. I have a wrong .Net or something). One of my colleagues tried the same script and it all worked fine for them on their machine. As said I have uninstalled lunchbox and reinstalled with no joy - might have to try removing all of rhino and reinstalling! Just wanted to check if anyone had had something similar before and knew of a fix

Edit: As a note the legacy reader is ok, just not the current one:

Cheers

1 Like

I had the exact same issue and resolved it by doing a quick repair on Office 365. I hope this works for you too!
image
image

@julian.parkes

And, in case that doesn’t do it, also see:

-wim