Loft problem

Hi! I’m trying to loft between these two curves. The problem is, the resulting loft is ‘twisted’ and ‘falls off’ mid-way.
I tried different combinations for the loft options but none fixe this issues (best result is refit but the surface is still uneven. I checked the control points and there doesn’t seem to be any mismatch. Could someone share guidance please? (11.2 KB)

1 Like

Can you show a screen shot of the result you are currently getting?

1 Like

I guess he is talking about this warp.


loft_problem Edited (16.5 KB)

It is fundamental, but I don’t understand it.
Shouldn’t the line connect 5 to 5, 6 to 6?
I tried to scale/move the front curve, it was always the same.
Why do we see this mismatch here?


Yes, it is as Quan shows. For some reason, I get a few seam line that doesn’t follow the curves, and the surface isn’t ‘taught’

1 Like

Thanks for testing this out Quan! It looks like the indexing of the curves is the same, but for the loft, the list is ‘shifted’. And this mismatch is mirrored to the other half of the curve too

1 Like

The result is the same in Rhino (left surface)

I would consider this type of loft as discrete parts to compensate for the corners, and then join them for a polysurface.


In fusion, if you loft these two curves, you have the option to keep the tangent edges.
I wonder how can I do that in GH.

Post edited:
In GH, I exploded the curves and lofted them separately.


Same as my solution, just more verbose :slight_smile:


Thanks very much Richard and Quan! This solved my problem and (I think?) maintained the curvature continuity. In this special case I found out I could have just extruded given how the curves are set up


Another option is to manually create the top portion of the curve as a single piece, but it more labor

I prefer creating simple surfaces instead of creating what I consider to be a complex curve.


Thank you! So it seems the straight line at the bottom partially cause the loft problem here.

I don’t think so. I think it’s more an issue with the discontinuities of the “polycurve”.

Your original curves have 6 pieces each. Lofting each one separately then joining them into a single polysurface works as shown in the previous examples.

The last example shows that a curve combined of two pieces, where the top section is a single section compared to your curve where it’s composed of 5 sections: 2 sides, 2 corners, 1 top.

I only did the last example to confirm to myself that the problem was with the loft command in general not working well with curves composed of multiple segments.


I see! The motivation for the complex version was to implement a fillet method I learnt from magicteddy. If I make the entire upper section into one curve, I won’t get straight parts of it to be straight (I’m assume by ‘single section’ you mean a single curve, rather than a few curves joined together). In this case the fillet part of the complex curve are actually curvature continuous to the straight line parts, but I guess that means little in the face of the problem with loft command here

1 Like

You can create straight sections in a continuous curves by placing control points in the correct locations, as I did in my example.


Hi Richard, sorry to bother you again. Could you please share some mode details for how to turn a complex curve (curve made by doing Join-Curves on a bunch of curves) into a simple curve? (just one curve, while keeping the linear parts linear)

It seems your simple curve in this picture has the same control points as mine. But when I try to rebuild the curve, the curve goes haywire (imprecise fit when I lower control points count, but lots of random/ugly twist and turns if I add more control points)

I used to think lofting was powerful, before I discovered surface networks.

With that aside though, obviously there’s pros and cons associated with merging different curvature areas together.

Which is why it doesn’t make sense to me for the curves described here to be joined into one curve “completely”.

I think it’s important to maintain isolation between the different curvature area inflection points.

Meanwhile, I’ve always found Rino’s ‘lofting’ to commonly ‘twist’ things. Usually, this is mitigated with controlling where curve seams are however.

I messed with it a bit, and found these options interesting:


It’s weird that those settings wouldn’t be assumed by default – if they were, then ‘loft’ wouldn’t be so notorious for twisting things.

When I think ‘loft’, I think ‘straight’ and ‘aligned’ lol. ‘Refit’ seems to help the most, which is weird too.

The 'refit’ment might have to be tighter, to improve the result more.

But if the curves were isolated somehow, then that might help too.

ew… tighter fitment made it worse … :thinking:

Maybe the loft is having trouble conforming to the degree 5 curves.

I tried rebuilding them, but that didn’t seem to help.

This is probably the best bet.

I’m just not sure the best way to join them… (12.8 KB)

I’m not sure why this wouldn’t bake as degree 5 … in that one direction…

1 Like

Sure. Create the curve, don’t rebuild it. Here’s how to do it in rhino. Notice how the control points follow the guide points. With a bit of creativity, you could re-create your original polycurve using the original control points using the same method shown here, but in Grasshopper.

1 Like

Thank you so much! I was able to recreate the simple version of my complex curve following your instructions

1 Like