List of Rhino 5 flaws on Windows 8 64-bit


#1

Lately I purchased a new laptop with pre-installed Windows 8 64-bit. So I installed Rhino 5 (64-bit). Before that I used to work on Windows 7 (86-bit).
Now I am experiencing some small things which are missing or doesn’t work properly in Rhino.

  1. When I am in perspective view and select object(-s) - camera doesn’t snaps to it as a centre of orbit rotation.
  2. In any of World views or CPlanes is not possible to cut/trim any object(-s) with line/surface if it’s not actually touching/intersects it.
  3. When running command “Select last created object” with preselected other object(-s) - it selects last creating object(-s) but deselect those which were preselected.

#2

None of these have anything to do with Windows 8, nor 32/64 bit.

  1. I don’t know what you’re comparing this to, but normally you have to “force” rhino to use a select object as center of rotation by doing a zoom selected. It has always been this way as far as I know.

  2. You should be able to split or trim surfaces/polysurfaces with curves that do not intersect, as long as the projection of the curve in the active viewport’s Z direction can actually cut the object. Make sure you have the correct viewport active. Curves can trim other curves in the same way, but not split them if they do not intersect. When using surfaces/polysurfaces as cutting objects a full intersection must be found.

  3. That is an option which you can set. Type -_SelLast (with the dash). You will get the following on the command line:

Change SelLast option. Press Enter when done ( DeselectOthersBeforeSelect=Yes ):

Click once on the link to change it to:

Change SelLast option. Press Enter when done ( DeselectOthersBeforeSelect=No ):

HTH, --Mitch


#3

are you talking about when using the gumball? if so, that’s a gumball preference ‘Rotate view around gumball’

otherwise, what mitch said.


#4

No, I use to just select object and instantly could rotate around it.
“Zoom selected” worked the same way but also actually zoomed an object.

I am not new to Rhino and quite sure that can spot which viewport is active. As I mentioned in my original post - I am writing about differences between I use to experienced before and what is going on now.

First of all, it use to work normally before. I have never choose any options for that command. It was always by default.
I am trying to write “_SelLast” but it runs normally as “SelLast”.

I am not talking about Gumball.

I think it might be a problem with my copy of Rhino, or Windows 8 or because it’s 64-bit. There is definitely something wrong. Too much weird things which never been there before.


#5

try it with the hypen ( - ) instead of an underscore ( _ )

how are you zooming? with a mouse? or a trackpad? any modifier keys?

as i understand, rhino has never automatically moved the target to an object allowing you to rotate around it but there are two main types of zoom in rhino… i personally don’t think either are optimum but if you’re using the zoom which is alt+scroll wheel, you’ll often end up with the target being behind the object you’re zooming to which can get really weird at times.


#6

Hi rainadil, when you´ve started the Trim command, make shure you have enabled the command option to use ApparentIntersections = Yes, im not shure if this is set to “No” by default.

as pointed out by Mitch one post above, you´ll need to set the hidden command option DeselectOthersBeforeSelect=No using _-SelLast not _SelLast

This may be related to Rhino Options / View / Pan / Auto adjust camera target after Pan and Zoom. Try to enable / disable it and see if you´ll get back your expected behaviour.

Sometimes i set command options and totally forget that i did and run into similar problems once i reinstall Rhino on a new system.

c.


#7

Usually I am using scroll weal on a normal 3-button mouse.

I understand what you mean. But Alt+scroll seems to not have any different effect from just a scroll. Maybe you meant to say Ctrl+Right button move?

It wasn’t turned on. I never knew about it. Now it works. Than you very much for that.

Once again “Bull’s Eye”. This option was also turned off. Now it’s working.
Thank you and Mitch.

I guess this is not my case. I couldn’t reset/switch those options earlier because I never knew they exist.
As I said - on my previous laptop with WIndows 7 and Rhino 5 - all these options were already turned on when I installed it.


#8

yeah… maybe… im on mac so the modifyer keys are different and my translation could be screwy

(edit) that said, do you by any chance use other 3d apps and may be confusing the navigation behaviors between it and rhino?


#9

no, no 3d navigators, manipulators or third-party software.


#10

oh… i meant do you use any other applications outside of rhino… as in-- do you ever use SketchUp?


#11

I also work in AutoCAD, Autodesk Inventor, 3ds max, but I don’t have installed them on this computer yet. If you meant that maybe some other software is interfering with Rhino?


#12

not interfering…

just that the navigation is different in other applications… some programs do act the way you originally mentioned in the top post:
"When I am in perspective view and select object(-s) - camera doesn’t snaps to it as a centre of orbit rotation."

(minus the bit about needing to select an object in order for it to be the center of rotation)…

so i was just thinking that maybe you’re used to one application behaving a certain way then going into rhino and thinking something has changed…
because, as far as i can gather, rhino has never acted the way you’re saying it did prior to you installing windows8… rhino’s camera has a set target and it stays in the same place and will continue to rotate around that point until you tell it to move somewhere else via one of the various zoom options… simply selecting an object or zooming towards an object will not reset the target onto that object.

i mentioned the gumball because you can set it up so the camera rotates around the gumball… or basically, if you select an object with gumball on while having a certain preference ticked, then the camera will rotate around the center of the object… but you’re saying it’s not gumball related which puts me back to the part about thinking you’re confusing rhino with a different app… or something :smile: