Link between GH and Rhino file lost

Hi, I’m a new rhino and grasshopper user.
In my tutorial projects, I’ve been saving both files with the same name and they open normally, but, in my last project, I closed both of them and, a couple of days later I opened them again, the GH file was ok and 3dm file opens empty, so I can’t see the GH geometry or the baked geometry.
My question is, how can I re-link the GH file into the rhino file or Can I link it to a new rhino file?

You can manually link the GH file to geometry in a new Rhino file. What happened to the original?

Thank you, Joseph… How can I do that?

I’m not sure what I did. I saved both of them before closed them and when I opened them again a recovery file window shows up in the rhino file, I clicked on the recovery option, then, the GH file opened with all the information in it and the 3dm opened empty.
I know that I have to save both files with the same name and to open the project first open the Gh file and the rhino file opens automatically.

Probably I did something wrong when I closed them.

No, that’s not true.

Have you recreated the geometry in a new file?

Ok. I thought that was a MUST to do.
No, I didn’t. You meant like to do it again from scratch in GH? No I didn’t.
It is not a big file, I can do that, however that bring me a new question for more complex and time taker projects. The GH files can be use in different files or be added to other files? like copy and paste kind of thing and have a library to use in new projects.

No, I meant do the Rhino geometry again that is used by your GH file.

ohh… I did everything in GH, no geometry was made in rhino.

Well no wonder the Rhino file was empty!!! Then what’s the problem? :man_facepalming:

The problem is, I can’t see the GH file in rhino, when I open the files nothing is showing in rhino’s file. So, I can’t link the Gh file to the rhino file. I don’t know how to do it.

This has NOTHINIG WHATSOEVER to do with “linking the Gh file to the rhino file”.

There are many possible reasons you aren’t seeing the GH output.

  • Have you enabled Preview on the component(s) you want to see?

  • Have you tried the ‘Zoom on Preview’ feature?

  • What render mode are you using?

Can you post your GH file?

3. Attach minimal versions of all the relevant files

This is the file (16.2 KB)

I’m using Wireframe.

All of your previews were hidden, some were disabled. Pull your socks up and turn on the lights! :sunglasses: (20.8 KB)

Thank you Joseph for your help and your patience. :grin:

Saints be praised! :wink: