Lighting - New user + Default lighting = WTF

Ok so I would assume that if I draw a box, I get a box. If I put a light on the scene, I get a light. I wouldn’t assume (and none of the other graphics apps I use for the last 20 years or so do this) that magical things that I have no control over and no way to turn off and given the flow of the rest of the program the inference is that it would only be there if I added it) would be placed inside my scene for me to STRUGGLE with as a new user.

I’m not a new user btw, I’m showing someone else and they are like “WTF” and I totally agree. I look at the complexity of a lighting scene and my normal routine is to draw a huge box, and put everything inside that box so I can control the scene and disregard the array of options that frankly are a waste of time. Adding a Sun is a great thing, adding a skylight etc is good but why on God’s green earth would you add a light behind a camera you cannot turn off and then NOT show it in the lights panel? Show it in the lights panel…and make things SIMPLE. The big box approach is works nicely because you can then see what your environment adds/removes to the scene because again, this is rather complex.


What you see here, is a glass sphere, inside a big old box, made from some opaque plaster material in black. This is AFAIK “correct” in terms of the laws of physics and everything that is sane.

Lets remove said big old box “wrapper”

Ta daaa! Magical lighting! With no way to turn it off, know its there, spend hours making something and then struggle for hours with lighting and then give up.

For clarity here are my settings:

So, given I’ve been doing this for quite a long time now and its my normal but when showing someone new this process they fall into the scared “this is way to complex” emotional state and quite frankly I agree with them. A new user is ALWAYS the best person to ask if a process is sane because they are looking at it with an untainted and pragmatic approach. Can some lovely kind person provide some light on the situation (punn intended) and is there a better way?

It would seem sensible to add a “camera light” option inside Tools > Options > Modeling Aids and have it default to off as if I didn’t draw it I didn’t assume it was on.



We add a default light when there are no others. The reason is simple…there are plenty of easier ways to create a black image than doing it Rhino! :wink:


Ok so if you add a single light to the scene…you get TWO lights.

Big box wrapper, single light source added to the scene

No big box wrapper, single light source

This is the scene for the last post.

The reason you add a default light where there are no others are to stop people creating totally black images?

In the 20 years that I’ve been using Rhino I’ve never had occasion to use anything but the default lighting for the kinds of things I do. It’s more than adequate. It doesn’t take much imagination to appreciate the support issues there would be if the default was no lighting at all.

On the other hand, I take it from this topic that your issue is that all user constructed lighting schemes are IN ADDITION to the default and there’s no way to turn off the default light if you want to use your own? If that’s the case I would agree that it seems kind of silly.

To cover both situations it would seem to me that the default light should be capable of being turned off, but only if there is at least one other light turned on. As soon as all the user lights are removed or turned off the default should be turned on and user control to turn it off should be shaded and/or have a reminder popup to tell the user he is trying to turn off the only light remaining.

Not a new user, but certainly one completely new to user-set lighting. Have I completely missed what this is about?

Spot on! This is precisely my issue. The default light affects reflections and when you are rendering small things close up with lots of reflections you essentially cant use any of the sun, or skylighting because of this problem. You end up re-creating it all. I would say it’s a modeling aid in every sense or if it isn’t, it’s a light that is automatically added, which is cool…I like the fact you can see your stuff on screen with no lighting setup but this is a light that should be added to the lights panel as it affects your view.

So I guess the answer is there isn’t a better way and thankyou AIW for your reply. If we all modeled things outside it wouldnt be an issue so much as the default light is quite a low level light. Im currently working on spaceships which are a whole load of fun but the lighting is so far outside of the “norm” in terms of lighting setup that you can see the camera light on the "wind"shield.


Hi @tbmstechnical,
Default lighting only applies when there are no more lights in the scene. If you place a light and use scene lighting the default light disappears as you can see in this image.

Just one light and one chrome sphere.

Could it be that you have modified the raytraced display mode and that those changes are overriding your render settings? Try to reset the display mode and test again, it should work.


1 Like

It does! José…thankyou for the light :slight_smile: and it always does amaze me how little I know the longer I spend time doing it. I stand totally corrected and I’m very very happy about that. I shall go back and admit I was wrong.

1 Like

It’s OK Tom, it happens to me too, Rhino it’s quite a big piece of software!