Light control ignores skylight

I can adjust the Sun Intensity value here, but not the Skylight.
And skylight shows as “1” no matter what.

As you can see I have sat the Skylight intensity down to 0.3:

I also think the lights panel should have sliders, so for environment one for intensity and one for rotation of the HDRI. For Sun it would be great with one for angle and one for rotation.

That way we could actually use the Light panel when lighting the models.

Throwing this on the list of @maxsoder

@Holo

I have problems to reproduce the problem with the Lights panel Skylight intensity. For me it updates the correct values.

Can I receive the output of the SystemInfo command?

About the new feature requests for the Lights Panel I think the ideas you presented would make a great addition. I was thinking that one could separate the Sun and Skylight to the top part of the Lights dialog with sliders. The rest of the lights could be in the list below.

Best Regards,
Max

Sure, Oh, and you guys need to put the CPU data into the SystemInfo. I have had many situations where Xeon’s run processes slower than other CPU’s. And AMD is known to not work too well with the RTX cards (In other apps that is, I don’t know about how that affects Rhino though), so knowing what kind of CPU(s) the system has could be of interest IMO.

I recreated the file now, and imported the fbx instead of opening it, and I get the same result.
When I change to a new HDRI and go to the Lights panel then any adjustments I try do do on the Intensity settings reverts back to “1”.


Rhino 7 SR13 2021-12-14 (Rhino 7, 7.13.21348.13001, Git hash:master @ 7696723f74a63695b3c372a89110c0ca8c78b890)
License type: Not For Resale Lab, build 2021-12-14
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 SUPER (NVidia) Memory: 8GB, Driver date: 4-8-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.31
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-8-2021
Driver Version: 27.21.14.6231
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 4.27.1.0
C:\Users\mail\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ggRhinoIFC\2.1.49.0\ggRhinoIFC.rhp “ggRhinoIFC” 2.1.49.0
C:\Users\mail\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.0\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.1.0.0
C:\Users\mail\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\Import_FBX.rhp “Import_FBX”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.13.21348.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”


NOTE: If I try to just adjust the default environment then it works OK, so try to import a new one. Maybe Rhino struggles when there are multiple environments in the file?

Thank you for the information. I can reproduce it now. If I set the environment as 360 backdrop environment, then intensity is stuck to the value of 1 in the lights panel.

yep, or just add a new environment and double click it to be the active one in all aspects.

I have made a fix for the intensity problem in the lights panel. The fix will be in v.7.15.

Br, Max

1 Like

Thanx Max!

I am currently experimenting with the lights panel. Maybe something like this and then remove the sun and skylight from the list.