Layout Space leader bug

Open file to Layout Space tab, double click into the detail then double click back out. The leader jumps off the object.

(6.10.18279.17351, 10/6/2018)

Eric

EricJumping Leader bug.3dm (429.8 KB)

Hi Eric - it is behaving here so far in 6.11, latest.

-Pascal

Hi Pascal,

This is what I get:
Before making detail active:

After making detail active:

Eric

Wow… I’ll go back to 6.10. I hope this is a thing that has ‘fixed’ on it.
@ejolley - this is OK in 6.10 here as well - just as a test, if you run `HistoryPurge’ on that leader, does it behave?

-Pascal

I recall that there was a history related problem related to dimensions that were created in an earlier SR of Rhino. I think I tested the fix about 2 months ago so if your leaders were created in a build prior to SR9, then they may have to be replaced.

Sorry my memory is more specific than that.

Hi John, yes I brought this up with you then. This is a completely new drawing.

Eric

Ugh. JB did you try this? I cannot repeat it here in 6.10 nor 6.11.

But… I do get the command line message

‘History failed to update 1 object.’

There is no reason for that, I would think.

-Pascal

I can’t repeat is in 6.9 either.
@ejolley
Can you post a small file that shows the problem please?

JB, it is in the first post.

-Pascal

I can not duplicate the problem in 6.9 using your file and instructions.
Nothing is jumping for me like you’re seeing.

Hmm. I guess that makes it likely graphics card related?

Hi Eric - I do not think so, there is something goofy here…

-Pascal

OK. Interestingly, when it jumps, I get ‘History updated 1 object’.

I’ll make a bug report - the History message I get is enough to go on, I think. Thanks.

https://mcneel.myjetbrains.com/youtrack/issue/RH-49029

-Pascal

I turned off 'Update Children". The behavior stopped.

Eric

Yep, HistoryPurge that thing, is what I’d do for now. You don’t want updating to be off and then have the thing jump later when you turn it on and you’re not looking.

-Pascal

My Update Children is still on.

OK thanks for that.