Leader justification

Last couple of WIPS have introduced and justification bug in the Leader command. Regardless of orientation or position, the test of the leader is always right justified. Cut and past the leader into V5 and it corrects itself.

@lowell, is this something that you are aware of?
The same issue is happening with text. That and a few other things…
I was trying to make an example file earlier today and multi-lined text refused to orient. Then I did something else and next thing I know, the multi-line was justified as it should.

That multi-line originated as single line and when selecting the multi-line later, only the initial single line would show in the properties box.

It’s also almost impossible to select text. You need to hit it right at its origin to get it to select. … but then that multi-line text all of a sudden was selectable anywhere…

I notices this a couple of WIPS ago, it wasent a problem before that, I reopen V6 drawings I know were correct when made but are now messed up. I bounce between the two version every now and again (I like the print quality/options of layouts in V6 more). I am aware of the multi line feature/ issue with the justification from a while back, I guess this is the same problem now extended to leaders.

Huh
Just noticed its an issue on single line leader text only, Add a second line and it corrects iself

No I’m not aware of it.

Are the leaders made with “Leader” or “RLeader”?
Is the text made with “Text” or RText"?

Are they made in the WIP or do they come from a file made with V5?

I just tried making some Leaders in the wip and didn’t see that problem.
If you have a simple file you can post?

Thanks,
Lowell

All made with Leader, I wasent aware of the Rleader options. Sample file attached is made in V6. Same leader was copied and the test edited to add a second line. If I copy and paste this into V5 and both are correct. If I copy and paste this into V5 and both are correct. Create leader in V5 copy and paste into V6 and the justification is messed up again.
leaders.3dm (42.3 KB)

Thanks Ken, I don’t know what I did to not see that a while ago because I do now.
I’ve been working on new annotation stuff and must have messed this up somewhere along the way.
I’ll see what I can find.

Text is made with “Text” - template is a RH5-format file (used both by my RH6 and RH6 installation).

Here is an example file.
2016-10-12 text-justification-wip.3dm (74.7 KB)

I’m not sure how to report the things that are happening - so here come a few screen shots:

This one shows the ‘bounding box’ of that one-liner when snapping to it to create a line. That text is center-mid justified and the point appears to be at that location but the box is all wrong. In order to be able to select that text, one needs to hit it within that bounding box.

This one shows that same line selected. The anchor point is left-bottom but should be cen-mid.

This one shows that there is no text in the properties panel for the text that is selected. That happens for 2 of the 3 text objects.

HTH

Thanks, I’ll see what I can find out

1 Like

@wim, @ken_miller - Thanks for reporting this.
We have been making quite a few changes in text drawing lately, and these look to be fallout from some of that.
If you run TestGlyphy to disable using Glyphy text drawing, the text will draw in the right place again. (Let me know if that’s not true.) Wim, As you said, your report is a little harder to pinpoint, but I’m almost sure it’s the same problem.
@stevebaer is working on the glyphy drawing and he’s out of town right now, but I’ll write it up and he’ll be back next week.
The reason picking and bounding boxes are disconnected from what you see is that they’re in the right place and the text is drawn in the wrong place when the justification isn’t left.

Thanks, Lowell

Thanks Lowell!

TestGlyphy does help, yes. The text is now inside the bounding box and changes to the left-cen-right justification in the properties panel are also done in the viewport. I tried a bit and saw that I could change the top-mid-bottom justification also but when I got back to bottom justification, any other changes are not implemented. That is, left-cen-right still works but changing from bottom to top doesn’t work.

I realize that this is probably something totally different but are you seeing that selected text doesn’t display in the properties panel? That is for any text string that has been changed. Well… if the string is multi-lined then nothing is displayed in the properties panel whereas if the string is single-lined, only the original text is shown.

Looks to be working here.
The new version does look to render sharper on the screen than when its disabled
Thanks for the help

WIm, The part about the wrong thing showing up in the edit box should be fixed now for the next WIP. I haven’t gotten to the vertical alignment part yet, but I do see it happen here.

1 Like