Layouts in floating viewport?

Is it no longer possible in rhino 7 to open layouts in one window and model in another? It’s super useful to be able to edit the model and see changes in the layout (esp. on two monitors) without toggling views.

Hi Sam - that works here - I can grab the layout viewport (by its title) and drag it off to a second monitor - is that what you mean?

-Pascal

Hey @pascal, thanks for the quick reply! No dice for me, but I’m realizing I forgot to specify that this was on Rhino for Mac – perhaps it’s only implemented in windows?

In 6 (on mac), activating layout view automatically opened a new window for layouts, but now that it’s in the same toolbar as the other viewports, that’s no longer true…

Indeed - on Mac, that seems to be locked in…
RH-61935 Layouts: Allow layouts to be detached to a floating window.

-Pascal

2 Likes

Yeah. Do you know of any workarounds? I guess it’s a #wish more than a #bug but it definitely was a nice feature when drafting in Rhino 6…

You can try turning off the IncludeLayoutsInDocumentWindow setting in preferences the opening a model with layouts. This is no longer an officially supported UI but it still mostly works.

Cool, thanks – will try that next time I’m in layout land.

I just upgraded to Rhino 7, and second the request to have a floating layout interface with the new design. I also use a two monitor set up and normally have one set up with the layout, and one with the model viewports. This is essential to my daily workflow (and I’m sure to many others), so it would be good to see it integrated into the Mac Rhino 7 without a workaround required.

I tried the suggested workaround and it seems to work, but not so smoothly, since the new list of layout sheets remains on the opposite window and not in the layout window.

Update some hours later:
I’m encountering a bug using layouts with the separate window workaround, where sometimes when I’m panning around a layout page, the screen will flash white every time I release the mouse button. This is only when panning with the mouse, not when moving around the drawing with my laptop’s trackpad, as shown in the screen recording attached. This happened in multiple drawings, but not on every layout page. In the attached Rhino file, it consistently happened every time I tried to navigate in the layout titled ‘plan tabloid’. When I changed the preferences back to the default layout setup (no longer in a separate window), the problem disappears.

Floating Layout Flashes White.3dm (4.2 MB)