Layers - Menu list - Sort by Name not working


#1

Hi

I’m using Version 5 SR8 64-bit

A recent bug that has crept in stops me sorting the Layers by name in the Layers Box, or what ever the correct name is.

Sometimes I can use it, sometimes it does not work.

Anyone else had this problem ?

John


(Pascal Golay) #2

Hi John- so, just to take the simplest case for now - if you make layers called A, B, C, E , F & G and move them around, and then sort by clicking at the top of the layer name column, it gets it wrong? That simple test works here…

-Pascal


#3

Hi

When I click the “Name” label in Layers, nothing happens.

As I said this happens more often than not.

I have just opened a new blank drawing created a series of blank layers, moved them around – no luck.

I then reset the toolbars to default and restarted Rhino

Still no luck, clicking “Name” is not working

Regards

John


(Pascal Golay) #4

Hi John - is there any action at all in the column header itself, like does the little up/down triangle to the left of the word 'Name" flip directions, or is it just as though you had not clicked on the ‘Name’ header at all? I am somewhat grasping at straws here since I have not heard of this… it almost seems like there is a utility of some kind running and getting in the way of mouse clicks. If you right click on the same header, do you see the context menu of available columns?

-Pascal


#5

It’s possible the column sort got turned off. Click the tools icon (hammer) in the layers palette and make sure there is a check mark next to ‘column sort’ at the bottom to be able to order by name, material, etc.

IIRC many people wanted a way to avoid accidentally ordering all the layers by mis-clicking on a column title, since there is no undo to get the previous order back. I leave column sort off, myself! Maybe a different name than column sort might be clearer…


(Pascal Golay) #6

Ah - good call! But, on the other hand, it seems only to happen sometimes… I’d expect either all the time or never, but let’s see what John finds there.

thanks,

-Pascal


#7

Thanks Pascal. I think sorting is on by default, and agreed it doesn’t make sense for it to be occasional. It was my only guess though. :smile: