Karamba 2: Youngs modulus is not correct when setting model unit to mm


I am using Karama When I change the input length unit to mm the material properties are 10^6 to high which lead to bad results. Is it a bug? Or should I change something in the ini file?
E should be equal to 3300 kN/cm2

Also the forces are visualised in kN/mm while I would rather see them in kN/m. Can I change this in the settings?

acting load is: 40 kN/m

And I am very happy with the new Cross section properties component which takes a polyline as input and calculates the sectional properties. Would be nice if it would also output a karamba cross section which can be used in your model. Is this part of the development roadmap of Karamba?

tower.gh (31.6 KB)

Hi @robinvdhave,
thanks for your bug-report! There is a conversion-error in reading material parameters from the external database. Sorry for the inconvenience. I will fix that as soon as possible.
Regarding the force units for display: In the next service release there will be a corresponding setting in the ini-file.
The possibility to define arbitrary cross sections in on the development roadmap (see Karamba3D 2.0.0 · GitHub) of Karamba3D.

Hi @robinvdhave,
there is a new service release (see https://github.com/karamba3d/K3D_NightlyBuilds/releases/tag/

  • The conversion bug is fixed.
  • The numbers at the load-symbols are now shown in the correct unit.


1 Like