Kangaroo 2 not working with high U and V counts for the mesh quads

grasshopper
mesh
kangaroo
kangaroo-2

(Víctor Ramírez) #1

I’m using Kangaroo to simulate how a structure is deformed by gravity, based on the definitions that are created on this tutorial using Kangaroo versions 0.099 and 2: https://youtu.be/ToHLlEGvhqA

Using Kangaroo 0.099 I have been able to make the simulation work; the preview mesh changes shape just as I change the values of the sliders:

However, when I try to do it with Kangaroo 2, the solver remains in the “Running” state for a long time, never gets to the “Converged” state, and thus the mesh preview doesn’t appear. It only works when I use extremely low values for the U and V counts of the mesh, but those values aren’t useful because they don’t display the shape with enough resolution:

What should I do to make the Kangaroo 2 solver work with a high U and V count (e.g. with a value of 50 in the slider, which has worked with the Kangaroo 0.099 solver)? Here’s the GH file:
Mesh simulation with Kangaroo v0.099 and v2.gh (56.7 KB)

Thanks for your attention!

P.S.:
Since the previews of both Kangaroo solvers lie on the same place, use the relays to activate and deactivate the Kangaroo 0.099 and Kangaroo 2 components, in order to visualize one simulation at a time. Also, you only need to experiment with the components that are inside of the groups. The components that are contained in the Cluster aren’t relevant and do not need to be changed.


(Daniel Piker) #2

I haven’t opened your file yet, but my first guess is that your edge length is getting lower than the tolerance setting of kangaroo, leading to vertices getting merged when they shouldn’t. Try reducing tolerance to 0.00001


(Víctor Ramírez) #3

Thanks a lot Daniel! Indeed that was the problem.

It feels great when you are learning to use a Grasshopper plugin and, from the very beginning, you manage to receive help from its creator!

Greetings from the Dominican Republic!