It doesn't bake revit structural framing and column to rhino

Hi Guys,

I tried to bake my revit structural steel framing/column element to rhino using RIR and elefront but when I do this, it only bake the analytic lines but not the physical steel element in rhino. Other revit elements like slab, roof and others bakes well inside rhino but steel framing and column it doesn’t, I am wondering maybe because they are revit families that are created by a sweep path by profile and not a solid geometry?
Any help is pretty much appreciated.

kind regards,
Joel

Can you send an example?

Normally you would run Revit elements into the Element geometry component, then run that geometry into the Elefront baker

Simple portal frame building.gh (36.3 KB)

Hi Scott,

Good day, please see attached gh file for review.
It seems like, only the analytic lines that bakes, there
must be something missing or error on my script.
I really do appreciate your help :).

Thank you,
Joel

Hi Scott,

Good day, any updates with the gh script?

Thank you,
Joel

The Level of Detail needs to be set to Fine to get a BREP out of Structural Framing members:

That should solve the problem.

Hi Scott,

Good day and thank you for your response, l will give a try on this and l will get back to you whatever the result will be.

Kind regards,
Joel

hi Scott,

Good day and thank you for your helpful response, it works now! and my next question, is there
a way to create definition wherein you can bake the element in rhino from revit
and at the same time assign/create a layer for it automatically?

Thank you and more power to your company.

kind regards,
Joel

Yes, use Elefront to do this. That will give you a lot of control.

There is an older definition here that uses Python code

We have simple bake process off any element geometry component. And we should get a Export button at some point on the toolbar that will do it.

Thank you Scott, it is amazing!

Kind regards,
Joel