Issues with Zoom & Image Generation on Rhino 6 Mac

Issue: When opening existing Rhino files on my computer into Rhino 6, I am having an issue where the background screen is blue and the image is distorted. Any time I rotate the image in perspective view, it multiplies and splits everywhere and I cannot see what I am doing.

Troubleshooting: I have tried restarting my computer, uninstalling and reinstalling Rhino. I have tried creating a new file and copy + pasting the items into it. Nothing seems to be working. It is not the file that is corrupt because when I open any existing Rhino file on my computer it is doing the same thing. If I create a new file and start modeling, I still have the same issue. I have attached images for your reference. Any help or advice is greatly appreciated!!

Update: It appears that it is mainly the Shaded viewport that is doing this. I have to work in either ghosted or wireframe which isn’t great but it’ll do for now.

Screen Shot 2020-05-14 at 2.09.24 PM|543x500

Something is goofy there.
Please fun the SystemInfo command in Rhino and post the results.
Hopefully something will jump out.



Here you go. Thank you for your help!

I see a couple things:

  • You are behind on updates to Catalina. You’re on 10.15.1. The current build is 10.15.4

  • In the Third party kernel extensions, I see 2 Parallels tools. I don’t think they will cause problems, but if the Catalina update doesn’t fix it, I’d start your Mac in safe mode to see if that sorts it:

  • You are way short on VRAM. For V6, you need a minimum of 4GB VRAM for each standard resolution monitor and 8 GB for each high resolution monitor. If you’re running 2 monitors, see what happens if you start up with only one.

Any luck?

The Catalina update didn’t fix it, and now when booting in safe mode and trying to open any Rhino file it just spins continuously trying to open it. Also, not sure what you mean about the VRAM (I am unfamiliar with this). At one point last month I was utilizing another monitor but the issue is there whether or not I am connected to a second monitor or just utilizing my main screen.

Mac Safemode is a way to start your mac without third party kernels.
Parallels is not a support tool for Rhino for Windows. Since this is a Mac question, my guess is it doesn’t matter, but I don’t know.
Reboot your mac normally (not safe mode).

Does this problem happen with all files or only this one?

This issue happens with all files…It’s very strange. & The parallels tools are from back when I installed it in 2015, I don’t use it anymore.

I’m not at all sure what to try next.
Perhaps reset your PLIST. That seems to be pretty fragile in Mac Rhino and can cause really bizarre behaviors.