Issues with material nodes & Family Types

Hello all,

First of my greatest thank yous and many gratitudes for creating Rhino.Inside Revit, this opened up a wide array of tools much needed for Reviters. and much more user friendly than Dynamo.

I really need your help with some issues that I just can’t seem to find a work around, and some seem like bugs (or maybe I just don’t know what I’m doing)

First item is creating materials with assets and a custom image. the script attached below seems to work perfectly when I’m working inside a revit family. however, it malfunctions when running the same script inside a project. it still creates the material and asset but fails to load the image in the appearance asset.

the second issues is setting a materials parameter for a family type. it seems to read the type parameter but doesn’t set the custom material I just created for the parameter.

Really need your help.



Hi Muthanna, I’ll take a closer look at this tomorrow but if i recall you will need to be in the family document to modify the assets of the material inside the family.

Hi Japhy, thank you so much for the quick response.

in this case I’m creating the materials within the project so I can assign them to a family type.

this is the other issue I ran into, I couldn’t query family types if I’m inside the family, so I have to do it within the project.

how could I assign a material to a family type?

A few questions…

Are you associating a material parameter in the Family Type?

You can do this if you are working with the Associated Material Parameter.

Editing the Material Asset in the Family is going to be problematic if you’ve already loaded it once into the Project. If the asset is changed in the Family its not going to be reflected in the project unless renamed. Same as how the Materials work.

Here is an example

Revit22_Material_Example.rvt (1.6 MB) (15.0 KB)

Japhy! this is amazing, everything worked like magic! I can’t believe it, this had me hung up the whole weekend, it turned out much simpler than I thought. following your script.

it was the query appearance asset node to set the template. for some reason this works without the asset template in a family but not a project.

also, thanks for this script, it has a few tricks I didn’t know before.

thank you so much, life saver.

1 Like